Bug 124219 - ttl of zero in broadcast frames
ttl of zero in broadcast frames
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Neil Horman
Brian Brock
:
Depends On:
Blocks: 116727
  Show dependency treegraph
 
Reported: 2004-05-24 15:56 EDT by Neil Horman
Modified: 2007-11-30 17:07 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-18 23:34:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to default the ttl of an ip header to /proc/sys/net/ipv4/ip_default_ttl (1.15 KB, patch)
2004-05-24 15:58 EDT, Neil Horman
no flags Details | Diff

  None (edit)
Description Neil Horman 2004-05-24 15:56:12 EDT
Description of problem:
sending net directed broadcasts results in a ttl of zero in the IP
header (conflicting with RFC1122)

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1.tcpdump a icmp request to a broadcast ip address
2.
3.
  
Actual results:
ip header has ttl of 0

Expected results:
ip header should have ttl specified by application specific IP_TTL
value from setsockopt, or from /proc/sys/net/ipv4/ip_default_ttl

Additional info:
Comment 1 Neil Horman 2004-05-24 15:58:27 EDT
Created attachment 100518 [details]
patch to default the ttl of an ip header to /proc/sys/net/ipv4/ip_default_ttl

This patch picks up ip_default_ttl on output for frames which don't have an
override ttl set via setsockopt.  It's up on kernel list now, but I wanted to
make sure we have a blocker bug to get it into RHEL3 U3
Comment 2 Neil Horman 2004-06-02 14:43:22 EDT
*** Bug 110387 has been marked as a duplicate of this bug. ***
Comment 7 Ernie Petrides 2004-06-05 00:32:00 EDT
A fix for this problem has been committed to the RHEL3 U3
patch pool this evening (in kernel version 2.4.21-15.6.EL).
Comment 8 Don Howard 2004-06-09 16:37:19 EDT
Moving from u4 to u3 blocker for tracking. 
Comment 9 Jay Turner 2004-08-18 09:59:52 EDT
Neil or others . . . is this looking good with the latest U3-candidate
kernel?
Comment 10 Neil Horman 2004-08-18 10:06:01 EDT
the test I just ran from your machine looks to be working fine.  Thanks!
Comment 11 Jay Turner 2004-08-18 23:34:37 EDT
Closing out based on feedback from original reporter.
Comment 12 John Flanagan 2004-09-02 00:31:38 EDT
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-433.html

Note You need to log in before you can comment on or make changes to this bug.