Bug 124288 - Character mode applications that use ncurses frames abecome messy using navigation keys
Summary: Character mode applications that use ncurses frames abecome messy using navig...
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: kdebase   
(Show other bugs)
Version: 2
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-25 13:44 UTC by Janos Lichtenberger
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-28 13:44:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X window dump (80.59 KB, image/jpeg)
2004-05-25 13:44 UTC, Janos Lichtenberger
no flags Details

Description Janos Lichtenberger 2004-05-25 13:44:13 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.1)
Gecko/20031114

Description of problem:
The frames or panels of an application (e.g. mc) started in kds
konsole become meesy using navigation keys (i.e. moving the highlight
between rows). It is true for application using full screen mode (mc,
crisp , etc.) I ecloses an X window dump of a mc panel

Version-Release number of selected component (if applicable):
kde-3.2.2-4

How reproducible:
Always

Steps to Reproduce:
1.start konsole in kde (Terminal)
2. in Konsole start mc
3. move up and down arrow in a directory 
    

Actual Results:  the symmetrical structure is spoiled, and the lines
are displayed wrongly 

Expected Results:  keeping the original structure

Additional info:

It was fine up to FC2Test3 and no problem in Gnome

Comment 1 Janos Lichtenberger 2004-05-25 13:44:43 UTC
Created attachment 100538 [details]
X window dump

Comment 2 Thomas E. Dickey 2004-05-29 12:06:16 UTC
Is mc linked with ncurses?  (I don't believe so).

Comment 3 Ngo Than 2004-07-28 13:44:29 UTC
i don't see this problem in FC2. it works for me here. Could you please 
try to configure your font setting in konsole.

mc just uses slang lib.


Comment 4 Janos Lichtenberger 2004-07-29 10:05:02 UTC
I used the default font setting of konsole. Also, it appers not only 
on the case of mc, but in the case of e.g. crisp console mode (cr). 
They both use 'frames' around text and these frames are spoilt after 
some pgup-pgdown together. I can attach xwd from other application if 
needed.


Note You need to log in before you can comment on or make changes to this bug.