Bug 124313 - Need updfstab entry for "IntelligentStick"
Summary: Need updfstab entry for "IntelligentStick"
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: hwdata   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-25 16:08 UTC by Aaron Schlaegel
Modified: 2014-03-17 02:45 UTC (History)
1 user (show)

Fixed In Version: 0.120-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-25 20:07:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Aaron Schlaegel 2004-05-25 16:08:38 UTC
Description of problem:
There needs to be an entry for "IntelligentStick" in
updfstab.conf.default.

This is a small usb pen drive.
General USB Disk Drive
kudzu reports:
 class: HD
 bus: SCSI
 detached: 0
 device: sda
 driver: ignore
 desc: "Usb card IntelligentStick"
 host: 1
 id: 0
 channel: 0
 lun: 0
 generic: sg1

Version-Release number of selected component (if applicable):
hwdata-0.118-1

Comment 1 Aaron Schlaegel 2004-05-25 16:11:10 UTC
I forgot to mention that it uses partition 1.

device flash {
    partition 1
    match   hd IntelligentStick
}

Comment 2 Bill Nottingham 2004-05-25 20:07:08 UTC
Added, will be in 0.120-1.

Comment 3 Ron Terry 2004-11-06 02:33:16 UTC
I have a 1GB version of the "IntelligentStick" and it will not work as
/dev/sda1, mount gives the error "mount: /dev/sda1 is not a valid
block device.".  It must be /dev/sda. The following entry is what
works for me:

device usbdisk {
    partition 1
    match hd IntelligentStick
}

Device info:

Vendor: I-Stick2  Model: IntelligentStick  Rev: 2.00
Type:   Direct-Access                      ANSI SCSI revision: 02
SCSI device sda: 2047488 512-byte hdwr sectors (1048 MB)
Attached scsi removable disk sda at scsi5, channel 0, id 0, lun 0
Attached scsi generic sg0 at scsi5, channel 0, id 0, lun 0,  type 0




Comment 4 Ron Terry 2004-11-06 02:36:38 UTC
I am sorry I sent wrong info on last post.  The entry that works for
me is:

device usbdisk {
    partition 0
    match hd IntelligentStick
}


Note You need to log in before you can comment on or make changes to this bug.