Bug 124315 - gd 2.0.26 is released
gd 2.0.26 is released
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gd (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
http://www.boutell.com/gd/
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-25 12:30 EDT by Robert Scheck
Modified: 2015-03-04 20:14 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-01 08:36:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2004-05-25 12:30:20 EDT
Description of problem:
gd 2.0.25 was released today and contains lots of fixes to the older
gd versions, for example "Binary transparency is now handled 
correctly in gdImageToPalette". More things are listed at the gd
homepage.

Version-Release number of selected component (if applicable):
gd-2.0.21-3

Actual results:
A diff from both spec files, I've got (gd 2.0.25 is up and running
here):

--- snipp ---
--- gd.spec       2004-04-21 15:40:19.000000000 +0200
+++ gd.spec.rsc   2004-05-25 18:20:26.000000000 +0200
@@ -1,12 +1,12 @@
 Summary: A graphics library for quick creation of PNG or JPEG images.
 Name: gd
-Version: 2.0.21
-Release: 3
+Version: 2.0.25
+Release: 1
 URL: http://www.boutell.com/gd/
-Source0: http://www.boutell.com/gd/http/gd-%{version}.tar.gz
+Source0: http://www.boutell.com/gd/http/%{name}-%{version}.tar.gz
 License: BSD-style
 Group: System Environment/Libraries
-BuildRoot: %{_tmppath}/%{name}-root
+BuildRoot: %{_tmppath}/%{name}-%{version}-root
 Prereq: /sbin/ldconfig
 BuildPrereq: freetype-devel, libjpeg-devel, libpng-devel, zlib-devel
 %define shlibver %(echo %{version} | cut -f-2 -d.)
@@ -73,6 +73,9 @@
 %{_libdir}/*.a

 %changelog
+* Tue May 25 2004 Robert Scheck <redhat@linuxnetz.de> 2.0.25-1
+- Upgrade to 2.0.25
+
 * Wed Apr 21 2004 Phil Knirsch <pknirsch@redhat.com> 2.0.21-3
 - Disable rpath usage.

--- snapp ---

Expected results:
Upgrade to 2.0.25... ;-)
Comment 1 Robert Scheck 2004-06-10 12:04:50 EDT
gd 2.0.26 has been released. gd 2.0.26 provides many significant 
improvements, including "configure" fixes, a new "-- features" option 
to gdlib-config, dramatically faster antialiased line drawing, more 
precise bounding box calculations in gdImageStringFT, support for 
named entities in gdImageStringFT, better documentation for 
gdImageStringFT, and more. See the what's new section of the gd 
2.0.26 manual for complete information: 
http://www.boutell.com/gd/manual2.0.26.html#whatsnew2.0.26

A simple upgrade from 2.0.25 to 2.0.26 worked for me very well, 
here's the diff:

--- snipp ---
--- gd.spec       2004-05-25 18:20:26.000000000 +0200
+++ gd.spec.rsc   2004-06-10 18:03:24.000000000 +0200
@@ -1,6 +1,6 @@
 Summary: A graphics library for quick creation of PNG or JPEG images.
 Name: gd
-Version: 2.0.25
+Version: 2.0.26
 Release: 1
 URL: http://www.boutell.com/gd/
 Source0: http://www.boutell.com/gd/http/%{name}-%{version}.tar.gz
@@ -73,6 +73,9 @@
 %{_libdir}/*.a

 %changelog
+* Thu Jun 10 2004 Robert Scheck <redhat@linuxnetz.de> 2.0.26-1
+- Upgrade to 2.0.26 (#124315)
+
 * Tue May 25 2004 Robert Scheck <redhat@linuxnetz.de> 2.0.25-1
 - Upgrade to 2.0.25 (#124315)

--- snapp ---
Comment 2 Robert Scheck 2004-06-11 07:58:27 EDT
I noticed after the upgrade to 2.0.26 a strange behaviour of gd: If I
create jpeg images using php with text on the image, the text is moved
too much to the top - using 2.0.25 this behaviour is not reproduceable.

Maybe you've got a look to it, before you do a update to 2.0.26. But 
I'm also able to provide an example for that strange behaviour. I'll 
try to talk with an upstream maintainer about this and post any news 
here.
Comment 3 Robert Scheck 2004-06-27 13:56:13 EDT
Okay, I talked with an upstream maintainer and it seems to be caused
by some (php) scripts having a double positioning fix, causing this 
behaviour.

All fine, update could be done...
Comment 4 Phil Knirsch 2004-07-01 08:36:24 EDT
Package has been updated yesterday. Rawhide versions should appear
over the next few days.

Read ya, Phil

Note You need to log in before you can comment on or make changes to this bug.