Bug 124338 - No sound after changing from "kdm - GNOME session" to "kdm - KDE session" (VT8233/A/8235/8237 AC97 Audio Controller)
No sound after changing from "kdm - GNOME session" to "kdm - KDE session" (VT...
Product: Fedora
Classification: Fedora
Component: kdebase (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
Ben Levenson
Depends On:
  Show dependency treegraph
Reported: 2004-05-25 15:06 EDT by Juan Hernandez
Modified: 2008-02-12 23:46 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-02-12 23:46:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Screenshot of the error message window. (14.58 KB, image/png)
2006-01-11 03:51 EST, Penelope Fudd
no flags Details

  None (edit)
Description Juan Hernandez 2004-05-25 15:06:20 EDT
From Bugzilla Helper: 
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.2; Linux) (KHTML, 
like Gecko) 
Description of problem: 
With a fresh install of Fedora Core 2 then soundcard is recognized 
and everything works fine. I can hear the sound test of 
"system-config-sound" without problems.  
Then I change the settings in "/etc/sysconfig/desktop" to use KDM 
instead of GDM as my preferred desktop manager. After rebooting, KDM 
appears and I choose KDE for the session. And suddenly the sound 
doesn't work anymore. 
I've tried setting "/etc/sysconfig/desktop" as it was before, so 
letting GDM be the desktop manager and choosing GNOME for the 
session, but sound doesn't work: I can hear nothing using 
"system-config-sound" for a test. 
As I've been trying for a long, even reinstalling the whole 
distribution, I can asure that there is no other change from the 
fresh install than the one I mention (KDM and KDE instead of GDM and 
I haven't made any change with alsamixer, kmix or similar by my own 
and looking at the settings with alsamixer they seem OK (not mute). 
Moreover, after reading some posts in Internet, I tried checking out 
"Sound Server" in KDE Control Center and also deselecting the option 
"load mixer settings" in the mixer section of Control Center, but 
nothing changes. 
Version-Release number of selected component (if applicable): 
alsa-lib-1.0.3a-2  kdemultimedia-3.2.2-2 
How reproducible: 
Steps to Reproduce: 
1.Reinstall a fresh Fedora Core 2 
2.Change settings in /etc/sysconfig/desktop from GNOME to KDE 
3.Test the sound with system-config-sound 
Actual Results:  No sound 
Expected Results:  The test sound playing	 
Additional info: 
Original content of "/etc/sysconfig/desktop": 
"/etc/sysconfig/desktop" after the change: 
Comment 1 Juan Hernandez 2004-05-25 15:07:02 EDT
Output from lscpi: 
00:00.0 Host bridge: VIA Technologies, Inc. VT8377 [KT400/KT600 AGP] 
Host Bridge 
00:01.0 PCI bridge: VIA Technologies, Inc. VT8235 PCI Bridge 
00:0c.0 SCSI storage controller: Adaptec AIC-7892A U160/m (rev 02) 
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 
Controller (rev 80) 
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 
Controller (rev 80) 
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 
Controller (rev 80) 
00:10.3 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 82) 
00:11.0 ISA bridge: VIA Technologies, Inc. VT8235 ISA Bridge 
00:11.1 IDE interface: VIA Technologies, Inc. 
VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06) 
00:11.5 Multimedia audio controller: VIA Technologies, Inc. 
VT8233/A/8235/8237 AC97 Audio Controller (rev 50) 
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] 
(rev 74) 
01:00.0 VGA compatible controller: nVidia Corporation NV34 [GeForce 
FX 5200] (rev a1) 
Output from lsmod: 
Module                  Size  Used by 
snd_pcm_oss            40740  0 
snd_mixer_oss          13824  3 snd_pcm_oss 
snd_via82xx            19104  3 
snd_pcm                68872  2 snd_pcm_oss,snd_via82xx 
snd_timer              17156  1 snd_pcm 
snd_ac97_codec         50436  1 snd_via82xx 
snd_page_alloc          7940  2 snd_via82xx,snd_pcm 
gameport                3328  1 snd_via82xx 
snd_mpu401_uart         4864  1 snd_via82xx 
snd_rawmidi            17184  1 snd_mpu401_uart 
snd_seq_device          6152  1 snd_rawmidi 
snd                    38372  11 
soundcore               6112  3 snd 
parport_pc             19392  1 
lp                      8236  0 
parport                29640  2 parport_pc,lp 
autofs4                10624  0 
sunrpc                101064  1 
via_rhine              15624  0 
mii                     3584  1 via_rhine 
floppy                 47440  0 
sg                     27552  0 
sr_mod                 13348  0 
nls_utf8                1536  1 
nls_cp437               5376  1 
vfat                   10496  1 
fat                    33472  1 vfat 
dm_mod                 33184  0 
joydev                  6976  0 
uhci_hcd               23708  0 
ehci_hcd               21896  0 
button                  4504  0 
battery                 6924  0 
asus_acpi               8472  0 
ac                      3340  0 
ipv6                  184288  10 
ext3                  102376  3 
jbd                    40216  1 ext3 
aic7xxx               135864  5 
sd_mod                 16384  4 
scsi_mod               91344  4 sg,sr_mod,aic7xxx,sd_mod 
Output from "cat /etc/modprobe.conf": 
alias eth0 via-rhine 
alias scsi_hostadapter aic7xxx 
alias snd-card-0 snd-via82xx 
install snd-via82xx /sbin/modprobe --ignore-install snd-via82xx 
&& /usr/sbin/alsactl restore >/dev/null 2>&1 || : 
remove snd-via82xx { /usr/sbin/alsactl store >/dev/null 2>&1 
|| : ; }; /sbin/modprobe -r --ignore-remove snd-via82xx 
alias usb-controller ehci-hcd 
alias usb-controller1 uhci-hcd 
Comment 2 Bill Nottingham 2004-05-25 16:08:50 EDT
If you run 'alsamixer' from the commandline, do you get a functional
Comment 3 Juan Hernandez 2004-05-26 04:39:09 EDT
¡Sorry very much! There´s a typographic error in the "Aditional info" 
section of the report. The correct settings 
in "/etc/sysconfig/desktop" after the cgange was:


Related to your cuestion, yes, running "alsamixer" from the command 
line shows the mixer and the settings seem ok: master volume and some 
others are set, and it seems to me the same values from the fresh 
I´ve tried this form a X console in Gnome and from a text console in 
runlevel 3.

Another point that may help is that the last time I reinstalled the 
system, I didn´t format my "home" partition, so the values stored in 
the home folder or subfolders doesn´t have any effect in the problem. 

I will try to show you the sequence I followed to reproduce the bug 
and get the sound working again:

1.- Install Fedora Core 2. Format "root" and "home" partitions.
2.- Use Gdm (default desktop manager) to log in a Gnome session.
3.- Change "/etc/sysconfig/desktop" to set DESKTOP="KDE" and 
4.- Restart the system.
5.- Use Kdm to log in a Kde session.
6.- The sound doesn´t work.
7.- Reinstall Fedora without formating the "home" partition.
8.- Use Gdm to log in Gnome. Everything OK.
Comment 4 Juan Hernandez 2004-05-26 07:31:53 EDT
I´ve read a post in <a
about 4 meters for VIA soundcards in "alsamixer" that say "VIA DXS"
and must be set to 100%. The problem, according to the post, is that
KDE sets these settings to 0% everytime you start it.

I will try this afternoon the workaround, setting the right values
manually, running "alsactl store" and creating a script in
~/.kde/Autostart to run "alsactl restore" with every KDE session. I
will append another comment to tell you if that solves my problem.

After all, it seems a KDE bug with VIA cards.

Thank you.
Comment 5 Juan Hernandez 2004-05-26 10:40:28 EDT
It seems that setting the right values for "VIA DXS" with alsamixer
and  assuring KDE desn't change them solves the problem.
Comment 6 Bill Nottingham 2004-05-26 15:38:44 EDT
Assigning to kdebase, then.
Comment 7 Matthew Miller 2005-04-26 11:33:48 EDT
Fedora Core 2 is now maintained by the Fedora Legacy project for
security updates only. If this problem is a security issue, please
reopen and reassign to the Fedora Legacy product. If it is not a
security issue and hasn't been resolved in the current FC3 updates or
in the FC4 test release, reopen and change the version to match.
Comment 8 Penelope Fudd 2006-01-11 03:49:32 EST
I've just installed FC4, and changed /etc/sysconfig/desktop to:


and I get the same problem.  The core of the problem is the command:

/usr/bin/artsd -F 10 -S 4096 -s 60 -m artsmessage -l 3 -f

It produces these error messages:
ALSA lib conf.c:1592:(snd_config_load1) _toplevel_:51:23:No such file or directory
ALSA lib conf.c:2837:(snd_config_hook_load) /etc/alsa/cards/aliases.conf may be
old or corrupted: consider to remove or fix it
ALSA lib conf.c:2700:(snd_config_hooks_call) function snd_config_hook_load
returned error: No such file or directory
ALSA lib pcm.c:1969:(snd_pcm_open_conf) Invalid type for PCM default definition
(id: default, value: cards.pcm.default)

And it produces a pop-up window, which I'm attaching.
Comment 9 Penelope Fudd 2006-01-11 03:51:50 EST
Created attachment 123042 [details]
Screenshot of the error message window.

This window pops up when you log in.
Comment 10 John Thacker 2006-10-25 15:53:20 EDT
Changing Version to FC4, per above comment.
Comment 11 Christian Iseli 2007-01-22 05:06:18 EST
This report targets the FC3 or FC4 products, which have now been EOL'd.

Could you please check that it still applies to a current Fedora release, and
either update the target product or close it ?

Comment 12 petrosyan 2008-02-12 23:46:17 EST
Fedora Core 4 is not maintained anymore.

Setting status to "INSUFFICIENT_DATA". If you can reproduce this bug in the
current Fedora release, please reopen this bug and assign it to the
corresponding Fedora version.

Note You need to log in before you can comment on or make changes to this bug.