Bug 124340 - suspend does not work on IBM thinkpad T23
suspend does not work on IBM thinkpad T23
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Depends On:
  Show dependency treegraph
Reported: 2004-05-25 15:11 EDT by Michael Zingale
Modified: 2015-01-04 17:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-04-16 00:21:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Michael Zingale 2004-05-25 15:11:44 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.3) Gecko/20030314

Description of problem:
Hi, I did a clean install of FC2 on an IBM Thinkpad T23, and the
system does not go into suspend mode.  On previous versions (RH 8, 9,
and FC1), this worked automatically after the install on this same
laptop, simply by closing the lid.  The laptop would then enter
suspend mode (suspending to memory NOT disk), and restore upon
openning the lid.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Install FC2
2. Try to suspend the laptop

Actual Results:  The laptop fails to enter suspend mode.

Expected Results:  In all previous versions of RH (8,9) and Fedora (1)
used on this laptop, it always went peacefully into suspend mode, and
restored without incident when openning the cover.

Additional info:
Comment 1 George Hein 2004-05-26 13:03:53 EDT
Same problems with Thinpads T20 and 240X.  (actually I think it did
suspend once, but would require a reboot to see screen).  I even tried
using acpi=ht and acpi=off, with no success.  
Comment 2 Ian Collier 2004-05-27 13:05:34 EDT
ACPI overrides APM when it is turned on at boot, and I am guessing
that closing the lid (or pressing Fn+F4) only works when APM is
enabled.  You can suspend the laptop with ACPI as mentioned here:
http://acpi.sourceforge.net/documentation/sleep.html (I'd probably
like to see a GNOME or KDE gizmo for this - I didn't see one when I
looked) but it's a bit flakey.  Standby in particular gives some odd

Specifying acpi=off at boot time does allow you to suspend the machine
by closing the lid, but the machine won't wake up again!  This is
because the FC2 kernel is compiled with APM_ALLOW_INTS unset, and this
is known to crash Thinkpads.

I've only just started with FC2, but I'll be compiling my own kernel
as soon as possible...
Comment 3 Arjan van de Ven 2004-05-27 13:07:27 EDT
> This is because the FC2 kernel is compiled with APM_ALLOW_INTS unset,
> and this is known to crash Thinkpads.

... and that is at runtime overridden via a detection algorithm that
detects IBM machines. APM_ALLOW_INTS config setting is only a default
that gets overridden for several laptop models...
Comment 4 George Hein 2004-05-27 20:37:26 EDT
This problem also is found in 2.6 MDK kernels but not in 2.4.25-5MDK
when under MDK92:

Note that APM-ALLOW-INTS is not set in any of MDK kernels that I have.
This kernel (2.4.25-5MDK)  works fine with suspend in the MDK9.2
environment, but not in either of the MDK10 environments.  

Sorry, I cannot compile kernel as I did not include compiler at
install and adding it later is no longer a simple function in either
MDK10 or FED2, this is unfortunate for both environments.  We are
going backwards at times.  
Comment 5 Michael Zingale 2004-05-27 22:25:15 EDT
actually, setting acpi=off fixes my problems.  The machine suspends
when I close the lid, and resumes without incident when I open it.

I will add this permanently to my kernel args list.
Comment 6 Ian Collier 2004-07-16 11:25:03 EDT
> ... and that is at runtime overridden via a detection algorithm that
> detects IBM machines.

Gosh, you are right and it's now working on 2.6.6-1.435.  But I did a
test with a newly installed FC2 and was pretty sure it locked the
machine up.  How strange.
Comment 7 Dimitris 2004-08-02 22:04:24 EDT
You can suspend a thinkpad with ACPI enabled with this command:

echo 3 >/proc/acpi/sleep

you can also make Fn-F4 work, by using the thinkpad keyboard daemon
which can execute that command for you. that tp util can be found
in Dag's repository.
Comment 8 Dave Jones 2005-04-16 00:21:37 EDT
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.