Bug 124348 - device-mapper-1.00.14-3 won't build as a normal user
device-mapper-1.00.14-3 won't build as a normal user
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: device-mapper-obsolete (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alasdair Kergon
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-25 16:40 EDT by Steve Grubb
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-26 12:56:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Grubb 2004-05-25 16:40:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.4.2)
Gecko/20040308

Description of problem:
One of the basic rules to building rpms is not to be root when you do
it so you don't hammer your machine if there's a scripting mistake.
device-mapper-1.00.14-3 absolutely requires you to be root because of
the install phase.

However, there is a configure option where you can tell it to do it as
a normal user for packaging purposes. The %files section makes sure
everything gets root permission, so its completely unnecessary to have
to be root to build this package.

To solve the problem, change the build section to this:

%build
%configure --enable-static_link --with-user=`whoami` --with-group=`whoami`
make
                                                                     
          

Version-Release number of selected component (if applicable):
device-mapper-1.00.14-3

How reproducible:
Always

Steps to Reproduce:
1. su - buildsys  ( or any other non privileged account )
2. rpmbuild -bb device-mapper.spec

    

Actual Results:  The package build dies during the %install phase with
permission denied messages.

Expected Results:  A message indicating where the rpm was written to.

Additional info:
Comment 1 Alasdair Kergon 2004-05-26 12:56:20 EDT
fixed in 1.00.17-2

Note You need to log in before you can comment on or make changes to this bug.