Bug 124365 - at regression test fails 7 days before the end of each month
at regression test fails 7 days before the end of each month
Status: CLOSED DUPLICATE of bug 108701
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: at (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
Mike McLean
Depends On:
  Show dependency treegraph
Reported: 2004-05-25 19:23 EDT by Charlie Bennett
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 14:03:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Charlie Bennett 2004-05-25 19:23:30 EDT
Description of problem:

Every month(!) if today + 1 week carries us into next month.

It's the 'next week + 1 month' and 'next week - 1 month' tests.
parsetest gets it right, the perl code in the regression test
gets it wrong.  I'll drop you a line when I have a patch.

It's failing today.  Succeeded yesterday and tomorrow.  Will
fail again on the 24th of June....

Version-Release number of selected component (if applicable):

This may affect this package in other releases.

How reproducible:

Like clockwork.

Steps to Reproduce:
1. set your system clock to May 25 or June 24 or July 25, etc.
2. run make test in the at build directory
Actual results:

tests of 'next week + 1 month' and 'next week - 1 month'
fail routinely.  tests of 'next week - 10 months' and
'next week + 10 months' fail for some months.

Expected results:

We expect the test harness to do at least as good at this
computation as the program it is testing.

Additional info:

The program under test gets it right.  The test harness is
the broken element.

I won't be moving forward tonight without generating a patch.
I'll post it here as soon as it's available.
Comment 2 Jens Petersen 2004-06-28 11:58:07 EDT
This is a duplicate of bug 108701 for RHEL3, but is still open
for FC2 and later I'm afraid.
Comment 3 Jason Vas Dias 2004-08-03 19:03:28 EDT
And for the latest at-3.1.8-56+ (with -t option).

I had to temporarily disable the 'make test' with  
  %define _without_check 1
to get it to build on July 29th - I wish I'd seen
this bug then!

It is on my to-do list to fix this, and I'll make 
a patch to 'test.pl' - this is not trivial.

At least I can confirm that at-3.1.8-57 passes the
test on August 3rd!

Comment 4 Jason Vas Dias 2004-08-04 19:01:05 EDT

*** This bug has been marked as a duplicate of 108701 ***
Comment 5 Red Hat Bugzilla 2006-02-21 14:03:46 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.