Bug 124367 - vim-minimal rpm doesn't depend on vim-common
vim-minimal rpm doesn't depend on vim-common
Status: CLOSED DUPLICATE of bug 123205
Product: Fedora
Classification: Fedora
Component: vim (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Karsten Hopp
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-25 20:37 EDT by Oliver Jones
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oliver Jones 2004-05-25 20:37:31 EDT
Description of problem:
The vim-minimal package no longer depends on vim-common.  This causes
terminal emulation problems when using vim.  Particularly with arrow keys.

When you enter insert mode via i or A and try and use the arrow keys
on your keyboard instead of moving the cursor A, B, C, and D,
characters are inserted along with new lines and the like.  If I
remember my ANSI BBS days the ANSI character codes for arrow keys are
ESC[A, ESC[C et al.  It appears VIM is not interpreting these ANSI
codes correctly.  Is this functionality dependant on the contents of
vim-common?  It certainly appears so as I installed the package and
the problems go away.

Version-Release number of selected component (if applicable):
6.2.457-1

How reproducible:
Always.

Steps to Reproduce:
1. Install vim-minimal.
2. run vi test.txt enter instert mode and use one of the arrow keys.
  
Actual results:
Escape codes are inserted into the buffer.

Expected results:
The cursor should move.

Additional info:
Fedora Core 1 vim-common dependencies:

[oliver] luna:~$ rpm -e vim-common
error: Failed dependencies:
        vim-common is needed by (installed) vim-enhanced-6.2.121-1
        vim-common is needed by (installed) vim-minimal-6.2.121-1
        vim-common is needed by (installed) vim-X11-6.2.121-1

Fedora Core 2 vim-common dependencies:
[oliver] atlas:~$ rpm -e vim-common
error: Failed dependencies:
        vim-common is needed by (installed) vim-enhanced-6.2.457-1
        vim-common is needed by (installed) vim-X11-6.2.457-1

Note vim-minimal is not listed (but it is installed).

Now this might have been intentional on the part of the Fedora Core
packagers.  Maybe they wanted vim-minimal to be very minimal and not
include a lot of the extra guff from vim-common.  However they have
practically erradicated the usefulness of vi as an editor for those of
us who can't remember the k,l,j etc movement keys.

Please revert to the old rpm dependencies.  Either that or package at
least some basic terminal emulation support with vim-minimal.

Thanks
Comment 1 Karsten Hopp 2004-05-26 05:22:25 EDT

*** This bug has been marked as a duplicate of 123205 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:03:46 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.