Bug 124373 - Stunnel installation problems
Stunnel installation problems
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: stunnel (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-25 22:17 EDT by Philip Balister
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: 4.0.5-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-27 17:48:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philip Balister 2004-05-25 22:17:17 EDT
The stunnel rpm has a few minor problems:

1) Directory /usr/var/run/stunnel doesn't exist
2) /etc/stunnel/stunnel.conf default uses nogroup rather than nobody
for the group

Set the owner/group for /usr/var/stunnel to nobody.nobody.

It would be really nice to have an /etc/init.d script to run stunnel
at boot time. I have one from when I installed stunnel a long time ago
from source. If it isn't in the current stunnel source I can add it here.

Thanks,

Philip
Comment 1 Nalin Dahyabhai 2004-05-27 17:48:16 EDT
The sample really shouldn't be used as-is, these are some of the
reasons.  Moving the sample file to the docs directory to keep that
confusion out.  Adding an init script isn't very practical because two
instances of stunnel would need to be started if both client and
server mode were desired, and the current init script machinery isn't
very good for that.

Slightly cleaning up the sample, and moving it to the documentation
directory, for future revisions.

Note You need to log in before you can comment on or make changes to this bug.