Bug 124379 - suggesting more file systems to pick from...
suggesting more file systems to pick from...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-25 23:42 EDT by daniel
Modified: 2015-01-04 17:06 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-02 22:49:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description daniel 2004-05-25 23:42:31 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a2)
Gecko/20040525 Firefox/0.8

Description of problem:
why only ext3? most distros allow you to use reiserfs, xfs, etc...
you seam to be the only distro supporting ext3 only...
are you saving this basic feature for your server products?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. install


Actual Results:  ext3 is the only file system available... why

Expected Results:  should be able to choose from ext3, reiserfs, xfs, etc

Additional info:

see suse... (just to give you an example)
Comment 1 Jeremy Katz 2004-05-26 16:04:22 EDT
anaconda has the support, they're just not enabled by default as a
distribution level decision.
Comment 2 daniel 2004-05-26 16:07:07 EDT
i know that, but why not enableing them by default?
suse has that and from my understanding suse is now kinda like a 
direct competitor... anyway, i think that it would be very nice to 
enable all the fs by default...

my2c
d
Comment 3 Bill Nottingham 2004-05-26 16:09:24 EDT
This falls down to what the kernel wants to support by default.
Comment 4 Dave Jones 2004-11-02 22:49:57 EST
suse enables all sorts of other things too. We're not blindly following them off
the cliff just because 'xxxx option is cool'.

It all comes down to what we consider to be supportable.
The other filesystems are available, but if you hit bugs in them, you're
basically on your own (take the pieces to the upstream maintainers).
Some users don't like this, so we don't make everything under the sun available.

Note You need to log in before you can comment on or make changes to this bug.