This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 124440 - OO displays incorrect fonts
OO displays incorrect fonts
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-26 12:28 EDT by An. N
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-27 11:08:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screenshot showing described behavior. (6.19 KB, image/png)
2004-05-26 12:29 EDT, An. N
no flags Details

  None (edit)
Description An. N 2004-05-26 12:28:24 EDT
Description of problem:
When using international characters with certain fonts (ie. Luxi
Sans), OO displays them in a font which is different than the one
currently selected, or displays blank characters. I wasn't able to
reproduce this behavior in any other application than OO.
Other popular fonts which produce this problem:
Bitstream Charter
Bitstream Vera Serif
Bitstream Vera Sans
Bitstream Vera Sans Mono
Courier 10 Pitch
Luxi Mono
Luxi Sans
Luxi Serif
Utopia

Version-Release number of selected component (if applicable):
openoffice.org-1.1.1-4
Fedora Core upgraded from 1 to 2

How reproducible:
Always

Steps to Reproduce:
1. Open OOWriter
2. Choose language: 'Polish'
3. Choose font: 'Luxi Sans'
4. Type in Polish characters

Actual results:
Characters in an other font than the one currently selected, or blank
characters.

Expected results:
Characters in the same font.

Additional info:
Please see the attached file for a screenshot.
My locale is pl_PL, however changing to en_US or pl_PL.UTF-8 did not
solve the problem.
Comment 1 An. N 2004-05-26 12:29:51 EDT
Created attachment 100596 [details]
Screenshot showing described behavior.
Comment 2 Tomas Mraz 2004-09-02 09:26:35 EDT
The problem is that the specified fonts don't contain these accented
characters.
However I think that what could be fixed is that the default fonts for
these EE (PL, CZ, HU,...) locales should be changed to something else
than Bitstream Vera. I suggest Nimbus family of fonts as these have
all required characters and they are even similar to Times and Arial.
Comment 3 Dan Williams 2004-09-18 13:13:32 EDT
In current 1.1.2 versions, PL, CZ, and HU use Nimbus family before
they use Luxi fonts...  Can you test please?  Thanks.
Comment 4 An. N 2004-09-30 14:38:24 EDT
Unfortunately I don't have the resources to test it, so I can't help
you out here :(. I solved the problem by copying TTF fonts from my MS
Windows installation (but that, of course, is not a very good workaround).
Comment 5 Dan Williams 2004-11-03 16:43:49 EST
Is this still a problem with the 1.1.2-10.fc2 update in Fedora Core 2?
Comment 6 Caolan McNamara 2005-01-27 11:08:49 EST
fix + no response => assume its ok :-), reopen (and attach a sample .sxw that
shows the problem if possible) if still broken with latest updates.

Note You need to log in before you can comment on or make changes to this bug.