Bugzilla will be upgraded to version 5.0. The upgrade date is tentatively scheduled for 2 December 2018, pending final testing and feedback.
Bug 124447 - Errormessage from pcm_hw.c
Errormessage from pcm_hw.c
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-26 13:00 EDT by Jochen Schmitt
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-10 06:05:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jochen Schmitt 2004-05-26 13:00:18 EDT
I am using kernel 2.6.6-1.381 and alsa-1.0.4.

After I start X/KDE I got the following error message:

ALSA lib pcm_hw.c:494:(snd_pcm_hw_start) SNDRV_PCM_IOCTL_START failed:
Broken pipe

The KDE system sound will not be played.

Best Regards:

Jochen Schmitt
Comment 1 Bill Nottingham 2004-05-26 15:27:53 EDT
What sound card?
Comment 2 Jochen Schmitt 2004-06-01 12:23:13 EDT
Ensoniq 5880 AudioPCI (rev 2)
Comment 3 Bill Nottingham 2004-06-01 14:38:06 EDT
Does upgrading arts from rawhide help at all?
Comment 4 Ngo Than 2004-06-01 16:32:45 EDT
which arts version did you install on your machine?
Please try 1.2.2.
Comment 5 Jochen Schmitt 2004-06-03 11:41:58 EDT
I have installed arts 1.2.2-4 and kernel 2.6.6-1.406.

On the commandline I can do a aplay <wavefile> but the sound is very poor.

But when I start KDE, I got the error message and I am hearing only a
permanent noise from the speaker.

Best Regards:

Jochen Schmitt
Comment 6 Petr Krištof 2004-06-10 04:58:26 EDT
My system is:
kernel-2.6.5-1.358
arts-1.2.2-2
kdebase-3.2.2-4

soundcard is
02:0d.0 Multimedia audio controller: Ensoniq ES1371 [AudioPCI-97] (rev 06)

system-config-soundcard detects card and plays 'guitar' OK.
Modules are loaded OK.
aplay plays wav OK.
I can also do 'cat /etc/passwd > /dev/dsp' OK
xmms plays music via OSS output plugin OK

But during startup of KDE i get error:
Sound server informational message.
Error while initializing the sound driver
device default cant be opened for playback (Permission denied)
The sound server will continue, using the null output device.

I did changed all /dev/dsp* /dev/mixer* to 0666 permission
but without effect.

Trying to debug arts I got the same error:
ALSA lib pcm_hw.c:494:(snd_pcm_hw_start) SNDRV_PCM_IOCTL_START failed:
Broken pipe
Comment 7 Ngo Than 2004-06-28 10:24:22 EDT
The error was caused in alsa. It looks like a bug there.
Comment 8 Martin Stransky 2005-05-10 06:05:42 EDT
It has been reported to upstream and bug tracks for it (or very
similiar bugs) are here:

https://bugtrack.alsa-project.org/alsa-bug/view.php?id=490
https://bugtrack.alsa-project.org/alsa-bug/view.php?id=880
https://bugtrack.alsa-project.org/alsa-bug/view.php?id=353
https://bugtrack.alsa-project.org/alsa-bug/view.php?id=397

I'm closing it as UPSTREAM.

Note You need to log in before you can comment on or make changes to this bug.