Bug 124452 - Invisible attachments in evolution's email compose window
Invisible attachments in evolution's email compose window
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
2
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-26 13:44 EDT by Tim Keitt
Modified: 2008-08-02 19:40 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-27 13:28:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Tim Keitt 2004-05-26 13:44:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040518 Firefox/0.8

Description of problem:
When composing email, if I choose the "view attachments" option and
drag a MS Office file into the attachments pane, it does not display.
The attachement does get sent to the recipient; it simply does not
display an icon in the composer window. A quick check suggests that
other file types display just fine -- I only had problems with word
and powerpoint files. Hmmm....

Version-Release number of selected component (if applicable):
Gnome evolution 1.4.6

How reproducible:
Always

Steps to Reproduce:
1. In evo, create new email
2. Select "view attachments" from menu
3. Drag an MS Office document onto the attachments pane
    

Actual Results:  No icon

Expected Results:  An icon

Additional info:
Comment 1 Mantas Kriaučiūnas 2004-06-01 07:36:20 EDT
I have this problem too. I found, that in Debian this problem can be
solved simply by installing gnome-icon-theme package
(look at http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=214448 and
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=237228 ), but on
Fedora Core 2 this doesn't help :(
Also I tried this -
http://www.mail-archive.com/evolution@lists.ximian.com/msg07356.html
but without luck too :(
I get these messages in terminal, when starting evolution from
terminal and tried to attach .doc file:

bash-2.05b$ evolution
 
(evolution:7792): GLib-GObject-WARNING **: g_object_set_valist:
construct property "type" for object `ESplash' can't be set after
construction
 
(evolution:7792): GdkPixbuf-CRITICAL **: file gdk-pixbuf-io.c: line
761 (gdk_pixbuf_new_from_file): assertion `filename != NULL' failed
 
(evolution:7792): GnomeUI-CRITICAL **: file gnome-icon-list.c: line
1219 (gnome_icon_list_append_pixbuf): assertion `im != NULL' failed
Comment 2 Mantas Kriaučiūnas 2004-06-01 10:33:39 EDT
It seems I found where is the problem. redhat-artwork package contains
buggy BlueCurve theme - when I remove /usr/share/icons/Bluecurve
folder  and set gnome theme to simple Evolution shows attachments.

Btw, I think severity of this bug should be Normal, becausi it's a bug
that should be fixed eventually and isn't minor loss of function.
Comment 3 Alexander Kain 2004-06-21 23:11:33 EDT
this happens to stock .wav files as well.
Comment 4 Peter van Egdom 2004-06-29 16:09:12 EDT
I experienced this bug too while adding a .zip file to an e-mail.
Comment 5 Hubert Grininger 2004-07-29 04:51:57 EDT
I experienced this bug too. A work-around is to 
run the gnome-theme-manager and choose another theme but the Fedora
Bluecurve.

I think this is an really annoying bug, because it hardens the writing
of emails with attachment. One can never be sure if the attachment has
been attached or not.
Comment 6 P Jones 2004-08-02 06:27:10 EDT
I'm also seeing this bug in FC2, but it does not occur on my laptop
running FC1. I checked the Ximian bugzilla, and it appears to be a
problem not exclusive to FC. Look here:
http://bugzilla.ximian.com/show_bug.cgi?id=48504 and here:
http://bugzilla.ximian.com/show_bug.cgi?id=48492 . Of course, both are
marked as resolved!

Another note, if I login using Gnome as my desktop, I don't have the
problem, if I login using KDE, I have the problem.

My FC2 is updated EXCEPT for libgnome and libbonobo. I had the problem
even after updating libbonobo, and rolled back to stock to see what
would happen.
Comment 7 Don Himelrick 2004-10-20 09:15:04 EDT
Another tiwst: If you add an attachment that doesn't show and then add
another attachment that does show, then right clicking on attachment
2 [details]'s icon (the only one visible) brings up the properties for the
invisible attachment 1 [details].  So  you end up deleting or whatever an 
invisible attachment.   This is a real pain in the arse and a real
usability problem.  Is this a bug with themes and mime types or with
evolution?
Comment 8 Don Himelrick 2004-10-20 09:23:51 EDT
Yeah, I think this should be at least a normal severity, like the guy
in comment 2 above.
Comment 9 chris 2004-11-03 05:21:33 EST
For what it's worth, this bug is still present with the
recently-released redhat-artwork-0.96-2 installed.
Comment 10 Matthew Miller 2005-04-26 12:01:25 EDT
Fedora Core 2 is now maintained by the Fedora Legacy project for
security updates only. If this problem is a security issue, please
reopen and reassign to the Fedora Legacy product. If it is not a
security issue and hasn't been resolved in the current FC3 updates or
in the FC4 test release, reopen and change the version to match.
Comment 12 John Thacker 2006-10-27 13:28:28 EDT
Closing per lack of response.  Also note that FC1 and FC2 are no longer
supported even by Fedora Legacy.  If this still occurs on FC3 or FC4, please
assign to that version and Fedora Legacy.  If it still occurs on FC5 or FC6,
please reopen and assign to the correct version.

Note You need to log in before you can comment on or make changes to this bug.