Bug 124461 - Problem compiling dbus
Problem compiling dbus
Status: CLOSED DUPLICATE of bug 123786
Product: Fedora
Classification: Fedora
Component: dbus (Show other bugs)
2
i686 Linux
medium Severity low
: ---
: ---
Assigned To: John (J5) Palmieri
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-26 15:33 EDT by Ben Smith
Modified: 2013-03-13 00:46 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:03:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rpmbuild output (6.00 KB, text/plain)
2004-05-26 17:08 EDT, Ben Smith
no flags Details
rpmbuild output (head) (38.73 KB, text/plain)
2004-05-26 18:29 EDT, Ben Smith
no flags Details

  None (edit)
Description Ben Smith 2004-05-26 15:33:47 EDT
Description of problem:

Building dbus from FC2 on FC1:
'rpmbuild -bb dbus.spec' ends with the following error:

File not found: /var/tmp/dbus-root/usr/bin/dbus-viewer

dbus may be missing a build-requires or something.  Regardless, it's
failing silently somewhere.  I am attaching a complete log.

Version-Release number of selected component (if applicable):

dbus-0.20-4.1.src.rpm

How reproducible:

very.
Comment 1 Ben Smith 2004-05-26 17:08:57 EDT
Created attachment 100611 [details]
rpmbuild output
Comment 2 John (J5) Palmieri 2004-05-26 17:58:55 EDT
Can you send me the configure stage output?  I suspect you are missing
a build dependancy that hasn't been added as a BuildRequires in the spec.
Comment 3 Ben Smith 2004-05-26 18:24:09 EDT
Sure (bugzilla wouldn't let me attach the whole output)
I'll see what I can attach...
Comment 4 Ben Smith 2004-05-26 18:29:41 EDT
Created attachment 100615 [details]
rpmbuild output (head)
Comment 5 John (J5) Palmieri 2004-05-26 18:46:09 EDT
You are missing both gtk+-2.0 and libxml-2.0 development libraries. 
Dbus itself does not have a dependency on either of these libraries
but the fedora packages do.  You can either install those packages or
edit the spec file.  I will be adding the BuildRequires to the spec.

*** This bug has been marked as a duplicate of 123786 ***
Comment 6 Red Hat Bugzilla 2006-02-21 14:03:49 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.