Bug 1245046 - Activation keys are not validated.
Summary: Activation keys are not validated.
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Activation Keys
Version: 6.0.8
Hardware: All
OS: All
unspecified
medium vote
Target Milestone: Unspecified
Assignee: Tom McKay
QA Contact: Cole Higgins
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2015-07-21 06:36 UTC by Mohammed Shakir Ali
Modified: 2021-12-10 14:29 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-04 18:01:32 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 18390 0 Normal New Activation keys are not validated. 2020-04-21 02:24:32 UTC

Description Mohammed Shakir Ali 2015-07-21 06:36:00 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:

By following the steps to create a new host group, provide a new
activation key that does not exist.


Steps to Reproduce:

In the step to provide activation keys, we are currently able
to add any value to activation keys. The host group is created without
validating existing activation keys.


Actual results:

A host group is created with non-existing activation keys.

Expected results:

There should be a way to select existing activation keys. The process should
validate the activation key name with existing activation keys.


Additional info:

Comment 1 RHEL Program Management 2015-07-21 06:44:15 UTC
Since this issue was entered in Red Hat Bugzilla, the release flag has been
set to ? to ensure that it is properly evaluated for this release.

Comment 6 Christine Fouant 2017-02-03 17:12:09 UTC
Created redmine issue http://projects.theforeman.org/issues/18390 from this bug

Comment 7 Satellite Program 2017-02-03 19:01:17 UTC
Upstream bug assigned to tomckay@redhat.com

Comment 11 Jong Bae KO 2018-07-18 01:36:08 UTC
Hi 

This bug is opened since Sat 6.0.8
Are we going to consider to fix in 6.4?


Thanks,
John Ko

Comment 13 Bryan Kearney 2018-09-04 18:01:32 UTC
Thank you for your interest in Satellite 6. We have evaluated this request, and we do not expect this to be implemented in the product in the foreseeable future. We are therefore closing this out as WONTFIX. If you have any concerns about this, please feel free to contact Rich Jerrido or Bryan Kearney. Thank you.


Note You need to log in before you can comment on or make changes to this bug.