Bug 124552 - system hang while probing for scsi CD writer with sym53c8xx and aic7xxx
Summary: system hang while probing for scsi CD writer with sym53c8xx and aic7xxx
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: xcdroast   
(Show other bugs)
Version: 2
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-27 13:51 UTC by Louis-Marius Pineau
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-21 14:00:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
output from DMESG with the Symbios adapter (15.06 KB, text/plain)
2004-05-27 13:52 UTC, Louis-Marius Pineau
no flags Details
output from DMESG with the Adaptec adapter (30.41 KB, text/plain)
2004-05-27 13:53 UTC, Louis-Marius Pineau
no flags Details

Description Louis-Marius Pineau 2004-05-27 13:51:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040207 Firefox/0.8

Description of problem:
when I try to add /dev/scd0 to the "add device manually" option, after
a while, the system hang. I repeated the process many time and I
managed to get the content of dmesg before the system get completely
locked up. Since I thought that my symbios scsi adapter was a bit old
(sym 53c875), I switched it with an adaptec (aha2940uw)and end up with
the same results but this time the adaptec adapter wa a bit more verbose.

I try to use cdrecord  with the scanbus option but this time it sees
the cdwriter but when I try to write to it, the system hang again but
this time, I was unable to get what got written with the dmesg command.

I can mount and read any CD whith this drive but not writing to it.

The writer was running perfectly with redhat 9 from which this system
was upgraded

Version-Release number of selected component (if applicable):
0.98a15-2

How reproducible:
Always

Steps to Reproduce:
1.start xcdroast
2.in the configuration pannel, select "Manually add device"
3.Add "/dev/scd0" anc click OK
4.do dmesg on another xterm to see what is going on from the kernel
until the system hang.
    

Actual Results:  The system hang and to escape from this, I have to
hit the reset button


Expected Results:  I should see the cd writer in the list and be able
to write with it

Additional info:

The system is a P4 1.7Ghz with 1Gb main memory on a EPOX 4BEA
motherboard. The system has the following configuration: 
SYM53c875 scsi adapter
   IBM Ultra 160 18Gb  as the boot drive (id 1)
   Seagate Ultra 320 36Gb as data drive  (id 8)
   Plextor 40/12/40S (id 4)
Aha 2950 scsi adapter
   HP Dat tape backup (DDS2)
   Conner 8Gb tape backup

This is what I get from the NCR driver before the system hang:
sym0:4:0:phase change 2-1 10@3f772360 resid=8.
sym0:1:0: ABORT operation started.
sym0:1:0: ABORT operation timed-out.
sym0:1:0: ABORT operation started.
sym0:1:0: ABORT operation timed-out.
sym0:8:0: ABORT operation started.
sym0:8:0: ABORT operation timed-out.
sym0:4:0: ABORT operation started.
sym0:4:0: ABORT operation timed-out.
sym0:8:0: ABORT operation started.
sym0:8:0: ABORT operation timed-out.
...


This is what I get from the Adaptec controller:
(scsi0:A:4:0): No or incomplete CDB sent to device.
scsi0: Issued Channel A Bus Reset. 1 SCBs aborted
(scsi0:A:4:0): No or incomplete CDB sent to device.
(scsi0:A:4:0): Protocol violation in Message-in phase.  Attempting to
abort.
scsi0:0:1:0: Attempting to queue an ABORT message
CDB: 0x2a 0x0 0x0 0x5b 0x53 0x78 0x0 0x0 0x8 0x0
scsi0: At time of recovery, card was not paused
>>>>>>>>>>>>>>>>>> Dump Card State Begins <<<<<<<<<<<<<<<<<
...

Comment 1 Louis-Marius Pineau 2004-05-27 13:52:30 UTC
Created attachment 100629 [details]
output from DMESG  with the Symbios adapter

Comment 2 Louis-Marius Pineau 2004-05-27 13:53:00 UTC
Created attachment 100630 [details]
output from DMESG  with the Adaptec adapter

Comment 3 Louis-Marius Pineau 2004-06-21 14:00:16 UTC
The problem has been solved by installing the latest kernel (2.6.6-1.435).


Note You need to log in before you can comment on or make changes to this bug.