Bug 124625 - IPv6 support missing
IPv6 support missing
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
: 126519 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-27 20:47 EDT by Dan
Modified: 2008-08-02 19:40 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-27 13:28:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Dan 2004-05-27 20:47:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040510

Description of problem:
Evolution 1.5 fails to connect to an IPv6 enabled Cyrus IMAP server.
It would seem Evolution doesnt understand IPv6 style IP addresses either.

Evolution 1.4 does connect to this  cyrus server fine. Evolution 1.5.8
does not.

The server's DNS entry has both AAAA and A records. Evolution 1.5 is
even failing to use the A record if AAAA is unreachable.

specfile has --enable-ipv6 but this seems to do nothing.

Telling evolution to connect to the IP address works. Telling
evolution to connect to the IPv6 address fails, as it tries to connect
to a machine called 2001, tcp port 360 (My ipv6 address is 2001:360...)

Version-Release number of selected component (if applicable):
1.5.8-1

How reproducible:
Always

Steps to Reproduce:
1. Configure Evolution to connect to IPv6 imap server
2. Press send/recieve
3. Evolution complains server is unreachable or uncontactable.
    

Actual Results:  Unable to check email.

Expected Results:  Should be able to log into IMAP using IPv6.

Additional info:
Comment 1 Dave Malcolm 2004-06-24 21:27:47 EDT
*** Bug 126519 has been marked as a duplicate of this bug. ***
Comment 2 Sean Middleditch 2004-08-17 10:24:37 EDT
Even better, this should be able to contact the server using IPv4.  I
have a mail server that is accessible over both IPv6 and IPv4. 
Evolution had always worked fine before.  A recent update in Fedora
Devel (likely in glibc packages) has caused the IPv6 address to be
returned before the IPv4 address in lookups.  (I can see this as
telnet connections attempt the IPv6 address first, fails, then tries
the IPv4 address, when it had always tried the IPv4 address first
before last week.)  I believe what is happening is that Evolution is
getting the IPv6 address, failing to connect, and not trying the
second address.

This not only causes problems with IPv6, but for _any_ setup where
fail over is necessary.  Services often have several addresses listed
in case the first ones fail.

As this bug stands, it is impossible to use Evolution on an
IPv6-enabled host.  This should be (IMO) a major bug, as it is a major
component of most Fedora desktops and needs to work independent of
IPv6 network availability.
Comment 3 Matthew Miller 2005-04-26 11:08:27 EDT
Fedora Core 2 is now maintained by the Fedora Legacy project for
security updates only. If this problem is a security issue, please
reopen and reassign to the Fedora Legacy product. If it is not a
security issue and hasn't been resolved in the current FC3 updates or
in the FC4 test release, reopen and change the version to match.
Comment 5 John Thacker 2006-10-27 13:28:00 EDT
Closing per lack of response.  Also note that FC1 and FC2 are no longer
supported even by Fedora Legacy.  If this still occurs on FC3 or FC4, please
assign to that version and Fedora Legacy.  If it still occurs on FC5 or FC6,
please reopen and assign to the correct version.

Note You need to log in before you can comment on or make changes to this bug.