Bug 124658 - Anaconda exception when installing from FTP
Anaconda exception when installing from FTP
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
2
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-28 06:07 EDT by André Johansen
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-09 11:07:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Dump from Anaconda, bzip2 compressed (79.82 KB, text/plain)
2004-06-02 02:29 EDT, André Johansen
no flags Details

  None (edit)
Description André Johansen 2004-05-28 06:07:45 EDT
From Bugzilla Helper: 
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.2; Linux) (KHTML, 
like Gecko) 
 
Description of problem: 
I booted from a local CD (diskboot.iso), and tried to install from 
FTP. 
 
After a custom package selection, Anaconda crashed with the 
following message: 
 
Traceback (most recent call last): 
  File "/usr/lib/anaconda/gui.py", line 1048, in 
handleRenderCallback 
    self.currentWindow.renderCallback() 
  File "/usr/lib/anaconda/iw/progress_gui.py", line 242, in 
renderCallback 
    self.intf.icw.nextClicked() 
  File "/usr/lib/anaconda/gui.py", line 763, in nextClicked 
    self.dispatch.gotoNext() 
  File "/usr/lib/anaconda/dispatch.py", line 169, in gotoNext 
    self.moveStep() 
  File "/usr/lib/anaconda/dispatch.py", line 237, in moveStep 
    rc = apply(func, self.bindArgs(args)) 
  File "/usr/lib/anaconda/packages.py", line 717, in doPreInstall 
    iutil.writeRpmPlatform(instPath) 
  File "/usr/lib/anaconda/iutil.py", line 644, in writeRpmPlatform 
    os.mkdir("%s/etc/rpm" %(root,)) 
OSError: [Errno 2] No such file or directory: 
'/mnt/sysimage/etc/rpm' 
 
Local variables in innermost frame: 
root: /mnt/sysimage 
rhpl: <module 'rhpl' from 
'/usr/lib/python2.3/site-packages/rhpl/__init__.py'> 
 
(I can send a the full dump in email on request.) 
 
Version-Release number of selected component (if applicable): 
 
 
How reproducible: 
Couldn't Reproduce 
 
Actual Results:  I had to reboot and start over.  On the second 
attempt, I chose a full install (to not wast too much time), but it 
seems to work now.
Comment 1 Jeremy Katz 2004-06-01 15:26:12 EDT
The full dump would be very helpful.  The most helpful would be
clicking the "Create a New Attachment" link and then attaching it to
the bug report.
Comment 2 André Johansen 2004-06-02 02:29:16 EDT
Created attachment 100786 [details]
Dump from Anaconda, bzip2 compressed
Comment 3 Jeremy Katz 2004-06-08 15:51:06 EDT
Can you reproduce this?  If you switch to tty2 when it happens, is
/mnt/sysimage mounted?
Comment 4 André Johansen 2004-06-09 02:24:02 EDT
I did try twice; once with a full install, then with custom 
selection, and both times worked.  I don't really want to reinstall 
my workstation now ;) 
Comment 5 Jeremy Katz 2004-06-09 11:07:16 EDT
I'm going to guess gremlins in the network :)
Comment 6 André Johansen 2004-06-10 02:56:13 EDT
Be aware that the FTP server is on the corporate LAN, so I doubt 
that is the problem... 
 

Note You need to log in before you can comment on or make changes to this bug.