Bug 1247054 - GetV2ImageBlob files in /var/lib/docker/tmp
GetV2ImageBlob files in /var/lib/docker/tmp
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: docker (Show other bugs)
7.3
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Daniel Walsh
atomic-bugs@redhat.com
: Extras
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-27 04:52 EDT by Chmouel Boudjnah
Modified: 2015-11-01 16:46 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-01 16:46:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chmouel Boudjnah 2015-07-27 04:52:21 EDT
Description of problem:

On an OpenShift environment we have seen a lot of files /var/lib/docker/tmp all files containers a lot of GetV2ImageBlob[0-9]+  files which goes to 33GB


This was as well reported and fixed upstream here :

https://github.com/docker/docker/issues/14506

and we would like to know if it was possible to have a backport

Version-Release number of selected component (if applicable):

docker-1.6.2-14.el7.x86_64

How reproducible:

I am not so sure this may be  investigated with the OpenShift team, the fix of the bug :

https://github.com/docker/docker/pull/14389

describe this has to do with files downloaded that weren't closed

Actual results:

files are not cleaned up in /var/lib/docker/tmp

Expected results:

files should be cleaned up in /var/lib/docker/tmp


Additional info:
Comment 2 Daniel Walsh 2015-07-27 11:09:52 EDT
This has not been fully approved fixed upstream yet.   We don't tend to back port since we release so often (Every 6 weeks, aproximately), we are releasing docker-1.7.1 in the next couple of weeks..  But that will not have the fix either.  As soon as upstream adopts the fix, we will get it into the next rhel7 release.
Comment 4 Daniel Walsh 2015-08-21 00:06:07 EDT
Fixed in docker-1.7.1-112.el7
Comment 5 Josep 'Pep' Turro Mauri 2015-11-01 16:46:34 EST
docker-1.7.1-115.el7 was shipped with RHBA-2015:1782:

https://rhn.redhat.com/errata/RHBA-2015-1782.html

which according to comment #4 includes a fix for this, so closing it.

Note You need to log in before you can comment on or make changes to this bug.