Bug 124706 - wrong redhat-release package in the channel
wrong redhat-release package in the channel
Status: CLOSED UPSTREAM
Product: Red Hat Network
Classification: Red Hat
Component: RHN/Channels (Show other bugs)
RHN Stable
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris MacLeod
Fanny Augustin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-28 13:50 EDT by Bill Nottingham
Modified: 2014-03-16 22:45 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-05 12:54:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2004-05-28 13:50:43 EDT
[root@elvis root]# up2date --show-channels
redhat-advanced-server-i386
[root@elvis root]# up2date --showall | grep redhat-release-as
redhat-release-as-2.1AS-11

However, if you look at this packge, you'll see it's the
redhat-release package for 2.1AS for ia64 ('Derry' in
/etc/redhat-release, the ia64 release notes, etc.)
Comment 1 John Flanagan 2004-05-28 14:20:04 EDT
Not sure how this ended up in the i386 channel.  What's in the i386 U4
tree is correct; as is the version Jay Turner posted to RHN via his
DIFF file at:

/mnt/redhat/test/RHEL2.1-U4-RHN.diff/rhel-2.1-u4/redhat-advanced-server-i386

rpm -pqi redhat-release-as-2.1AS-11.noarch.rpm
Name        : redhat-release-as            Relocations: (not relocateable)
Version     : 2.1AS                             Vendor: Red Hat, Inc.
Release     : 11                            Build Date: Wed 14 Apr
2004 03:28:53 PM EDT
Install date: (not installed)               Build Host:
boris.devel.redhat.com
Group       : System Environment/Base       Source RPM:
redhat-release-as-2.1AS-11.src.rpm
Size        : 117113                           License: GPL
Signature   : DSA/SHA1, Fri 16 Apr 2004 02:45:22 PM EDT, Key ID
219180cddb42a60ePackager    : Red Hat, Inc.
<http://bugzilla.redhat.com/bugzilla>
Summary     : Pensacola release file
Description :
Pensacola release file


Comment 2 Chris MacLeod 2004-06-03 17:00:45 EDT
If I recall correctly what happened was this package was originally
released for ia64 with that NVRE, then when the i386 errata was
released the release was not incremented and it conflicted when
uploaded.  Somebody signed off on that as being ok (I guess since the
NVRE was the same) but in reality only the ia64 one was there and got
associated with the i386 channel since it was the package that was there.

I think the correction is to errata a newer redhat release for i386
that is the correct package but I'll defer to misa on that being the
correct course of action.
Comment 3 Chris MacLeod 2004-07-09 13:24:37 EDT
This is apparently breaking satellite provisioning kickstarts as well
now b/c of the headers differeing between the hdlist/anaconda and the
package in the channel.

The fix is as follows:
push the correct redhat-release package from the authoritative i386
tree into production RHN.  This will allow satellites to
kickstart/provision correctly (with some possible minor resyncing on
the satellite).  
This will however put the i386 package into the ia64 channel (since
they share an NVRE)  We may want to fix this long term by errataing a
new version of the redhat-release package for both i386 and ia64 (or
potentially only ia64)

Note You need to log in before you can comment on or make changes to this bug.