Bug 1247092 - rpm: Add support for weak dependencies to rpmdeps tool
rpm: Add support for weak dependencies to rpmdeps tool
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: packaging-team-maint
Fedora Extras Quality Assurance
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-27 06:24 EDT by Mikolaj Izdebski
Modified: 2015-10-23 10:47 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-23 10:47:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mikolaj Izdebski 2015-07-27 06:24:03 EDT
Description of problem:
rpm 4.12.90 added support for generating weak dependencies through rpmfc, but rpmdeps tool (/usr/lib/rpm/rpmdeps) was not updated to support them.

Please add support for all other types of dependencies (i.e. suggests, supplements, enhances, conflicts, obsoletes) to rpmdeps tool.

Version-Release number of selected component (if applicable):
rpm-4.12.90-1.fc24.x86_64
Comment 1 Mikolaj Izdebski 2015-07-27 06:27:30 EDT
(In reply to Mikolaj Izdebski from comment #0)
> [...] all other types of dependencies (i.e. suggests,
> supplements, enhances, conflicts, obsoletes) [...]

And of course "recommends"
Comment 3 Ľuboš Kardoš 2015-10-23 10:47:17 EDT
rpm-4.13.0-0.rc1.7.fc24

Note You need to log in before you can comment on or make changes to this bug.