Bug 1247104 - Can't access dancer quickstart with perl-516-rhel7
Can't access dancer quickstart with perl-516-rhel7
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Templates (Show other bugs)
3.0.0
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Scott Dodson
Gaoyun Pei
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-27 06:50 EDT by XiuJuan Wang
Modified: 2015-11-23 09:44 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-23 09:44:05 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description XiuJuan Wang 2015-07-27 06:50:08 EDT
Description of problem:
Get 500 error when access dancer app with perl-516-rhel7
Works for dancer with perl-516-centos7

Version-Release number of selected component (if applicable):
rcm-img-docker01.build.eng.bos.redhat.com:5001/openshift3/perl-516-rhel7 (imageid a85bba603b33)

How reproducible:
always

Steps to Reproduce:
1.Create a dancer app using perl-516-rhel7 following https://github.com/openshift/dancer-ex
2.Acess dancer app via route(has resolved dns issue)
3.

Actual results:
Got 500 Internal Server Error

Expected results:
Could access dancer app with perl-516-rhel7

Additional info:
Comment 2 Scott Dodson 2015-07-27 15:50:26 EDT
This is happening because dancer-ex uses the new /opt/app-root/ path in the config but the image still uses /opt/openshift

1) Are other examples susceptible to this?
2) Are we ok with rebuilding only the perl image to handle this?

see https://github.com/openshift/dancer-ex/pull/19/files
Comment 3 Ben Parees 2015-07-27 16:03:37 EDT
Thanks Scott... yeah Dancer is the only repo that was updated for the app-root change so we should be ok with just a perl rebuild.  Sorry I forgot about that :(
Comment 4 Scott Dodson 2015-07-27 17:05:12 EDT
This should be fixed in this rebuilt image

REPOSITORY                                                                     TAG                                                IMAGE ID            
rcm-img-docker01.build.eng.bos.redhat.com:5001/openshift3/perl-516-rhel7       5.16_3                                             877aab167e52
Comment 5 XiuJuan Wang 2015-07-28 03:42:08 EDT
This issue has fixed with perl-516-rhel7(imageid 877aab167e52)
Could access dancer apps.

Note You need to log in before you can comment on or make changes to this bug.