Bug 1247111 - hammer repository-set available-repositories is failing in snap14
hammer repository-set available-repositories is failing in snap14
Status: CLOSED NOTABUG
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Hammer (Show other bugs)
6.1.0
x86_64 Mac OS
medium Severity high (vote)
: Unspecified
: 6.1
Assigned To: Brad Buckingham
Tazim Kolhar
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-27 07:14 EDT by Tazim Kolhar
Modified: 2017-09-19 13 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-02 07:12:28 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
foreman-debug attached (3.72 MB, application/x-xz)
2015-07-27 07:14 EDT, Tazim Kolhar
no flags Details

  None (edit)
Description Tazim Kolhar 2015-07-27 07:14:18 EDT
Created attachment 1056553 [details]
foreman-debug attached

Description of problem:
 hammer repository-set available-repositories is failing in snap14

Version-Release number of selected component (if applicable):

# rpm -qa |grep foreman
foreman-gce-1.7.2.32-1.el6_6sat.noarch
ruby193-rubygem-foreman_bootdisk-4.0.2.13-1.el6_6sat.noarch
ruby193-rubygem-foreman_gutterball-0.0.1.9-1.el6_6sat.noarch
qe-sat6-rhel66.usersys.redhat.com-foreman-proxy-1.0-2.noarch
foreman-debug-1.7.2.32-1.el6_6sat.noarch
foreman-ovirt-1.7.2.32-1.el6_6sat.noarch
rubygem-hammer_cli_foreman-0.1.4.14-1.el6_6sat.noarch
foreman-selinux-1.7.2.13-1.el6_6sat.noarch
foreman-postgresql-1.7.2.32-1.el6_6sat.noarch
foreman-1.7.2.32-1.el6_6sat.noarch
ruby193-rubygem-foreman-redhat_access-0.2.1-1.el6_6sat.noarch
rubygem-hammer_cli_foreman_tasks-0.0.3.5-1.el6_6sat.noarch
rubygem-hammer_cli_foreman_discovery-0.0.1.10-1.el6_6sat.noarch
ruby193-rubygem-foreman_docker-1.2.0.18-1.el6_6sat.noarch
ruby193-rubygem-foreman_hooks-0.3.7-2.el6_6sat.noarch
puppet-foreman_scap_client-0.3.3-9.el6_6sat.noarch
ruby193-rubygem-foreman_discovery-2.0.0.18-1.el6_6sat.noarch
rubygem-hammer_cli_foreman_bootdisk-0.1.2.7-1.el6_6sat.noarch
foreman-compute-1.7.2.32-1.el6_6sat.noarch
ruby193-rubygem-foreman-tasks-0.6.15.4-1.el6_6sat.noarch
foreman-proxy-1.7.2.5-1.el6_6sat.noarch
qe-sat6-rhel66.usersys.redhat.com-foreman-client-1.0-1.noarch
qe-sat6-rhel66.usersys.redhat.com-foreman-proxy-client-1.0-1.noarch
foreman-vmware-1.7.2.32-1.el6_6sat.noarch
foreman-libvirt-1.7.2.32-1.el6_6sat.noarch
rubygem-hammer_cli_foreman_docker-0.0.3.9-1.el6_6sat.noarch

How reproducible:
everytime

Steps to Reproduce:
1. hammer -v -u admin -p changeme --output=csv repository-set available-repositories --product-id="6983" --id="1699" --organization-id="1194"
2015-07-27 15:28:18 - robottelo.common.ssh - INFO - Instantiated Paramiko client 0x3723f10
2015-07-27 15:28:23 - robottelo.common.ssh - INFO - Destroying Paramiko client 0x3723f10
2015-07-27 15:28:24 - robottelo.common.ssh - INFO - Destroyed Paramiko client 0x3723f10
2015-07-27 15:28:24 - robottelo.common.ssh - DEBUG - <<< stderr
[ERROR 2015-07-27 05:58:23 Exception] private method `select' called for nil:NilClass
private method `select' called for nil:NilClass
[ERROR 2015-07-27 05:58:23 Exception] 

RestClient::InternalServerError (500 Internal Server Error):
    /usr/lib/ruby/gems/1.8/gems/rest-client-1.6.7/lib/restclient/abstract_response.rb:48:in `return!'
    /usr/lib/ruby/gems/1.8/gems/rest-client-1.6.7/lib/restclient/request.rb:230:in `process_result'
    /usr/lib/ruby/gems/1.8/gems/rest-client-1.6.7/lib/restclient/request.rb:178:in `transmit'
    /usr/lib/ruby/1.8/net/http.rb:543:in `start'
    /usr/lib/ruby/gems/1.8/gems/rest-client-1.6.7/lib/restclient/request.rb:172:in `transmit'
    /usr/lib/ruby/gems/1.8/gems/rest-client-1.6.7/lib/restclient/request.rb:64:in `execute'
    /usr/lib/ruby/gems/1.8/gems/rest-client-1.6.7/lib/restclient/request.rb:33:in `execute'
    /usr/lib/ruby/gems/1.8/gems/rest-client-1.6.7/lib/restclient/resource.rb:54:in `get'
    /usr/lib/ruby/gems/1.8/gems/apipie-bindings-0.0.11/lib/apipie_bindings/api.rb:279:in `send'
    /usr/lib/ruby/gems/1.8/gems/apipie-bindings-0.0.11/lib/apipie_bindings/api.rb:279:in `call_client'
    /usr/lib/ruby/gems/1.8/gems/apipie-bindings-0.0.11/lib/apipie_bindings/api.rb:210:in `http_call'
    /usr/lib/ruby/gems/1.8/gems/apipie-bindings-0.0.11/lib/apipie_bindings/api.rb:161:in `call'
    /usr/lib/ruby/gems/1.8/gems/apipie-bindings-0.0.11/lib/apipie_bindings/resource.rb:14:in `call'
    /usr/lib/ruby/gems/1.8/gems/hammer_cli-0.1.4.11/lib/hammer_cli/./apipie/command.rb:43:in `send_request'
    /usr/lib/ruby/gems/1.8/gems/hammer_cli_foreman-0.1.4.14/lib/hammer_cli_foreman/commands.rb:185:in `send_request'
    /usr/lib/ruby/gems/1.8/gems/hammer_cli_foreman-0.1.4.14/lib/hammer_cli_foreman/commands.rb:271:in `send_request'
    /usr/lib/ruby/gems/1.8/gems/hammer_cli_foreman-0.1.4.14/lib/hammer_cli_foreman/commands.rb:291:in `execute'
    /usr/lib/ruby/gems/1.8/gems/clamp-0.6.2/lib/clamp/command.rb:67:in `run'
    /usr/lib/ruby/gems/1.8/gems/hammer_cli-0.1.4.11/lib/hammer_cli/./apipie/../abstract.rb:23:in `run'
    /usr/lib/ruby/gems/1.8/gems/clamp-0.6.2/lib/clamp/subcommand/execution.rb:11:in `execute'
    /usr/lib/ruby/gems/1.8/gems/clamp-0.6.2/lib/clamp/command.rb:67:in `run'
    /usr/lib/ruby/gems/1.8/gems/hammer_cli-0.1.4.11/lib/hammer_cli/./apipie/../abstract.rb:23:in `run'
    /usr/lib/ruby/gems/1.8/gems/clamp-0.6.2/lib/clamp/subcommand/execution.rb:11:in `execute'
    /usr/lib/ruby/gems/1.8/gems/clamp-0.6.2/lib/clamp/command.rb:67:in `run'
    /usr/lib/ruby/gems/1.8/gems/hammer_cli-0.1.4.11/lib/hammer_cli/./apipie/../abstract.rb:23:in `run'
    /usr/lib/ruby/gems/1.8/gems/clamp-0.6.2/lib/clamp/command.rb:125:in `run'
    /usr/lib/ruby/gems/1.8/gems/hammer_cli-0.1.4.11/bin/hammer:108
    /usr/bin/hammer:19:in `load'
    /usr/bin/hammer:19


2.
3.

Actual results:
the command fails

Expected results:
the command works as expected

Additional info:
foreman-debug attached
Comment 2 Brad Buckingham 2015-08-18 15:40:21 EDT
Hi Tazim, can you re-run the above test on the 6.1.1 GA build?

I have run several tests on both dev environment and production install and am not able to reproduce the error.

E.g the following is the output I see:

hammer> repository-set available-repositories --organization-id 1 --product-id 110 --id 1446
---------------------------------------------------------------------------------|--------|---------|--------
NAME                                                                             | ARCH   | RELEASE | ENABLED
---------------------------------------------------------------------------------|--------|---------|--------
Red Hat Enterprise Linux 6.2 Scalable File System for RHS 2 VSA Beta RPMs fro... | x86_64 |         | no     
---------------------------------------------------------------------------------|--------|---------|--------
hammer>
Comment 3 Tazim Kolhar 2015-09-02 07:12:28 EDT
Hi,

   tested with latest snap - sat6 6.1.2 snap1

    
    rpm -qa | grep foreman
    ruby193-rubygem-foreman_discovery-2.0.0.19-1.el7sat.noarch
    ruby193-rubygem-foreman_docker-1.2.0.20-1.el7sat.noarch
    rubygem-hammer_cli_foreman_discovery-0.0.1.10-1.el7sat.noarch
    foreman-proxy-1.7.2.5-1.el7sat.noarch
    foreman-libvirt-1.7.2.35-1.el7sat.noarch
    foreman-compute-1.7.2.35-1.el7sat.noarch
    foreman-gce-1.7.2.35-1.el7sat.noarch
    ruby193-rubygem-foreman-redhat_access-0.2.3-1.el7sat.noarch
    rubygem-hammer_cli_foreman_tasks-0.0.3.5-1.el7sat.noarch
    dell-per805-01.rhts.eng.bos.redhat.com-foreman-proxy-client-1.0-1.noarch
    foreman-debug-1.7.2.35-1.el7sat.noarch
    foreman-ovirt-1.7.2.35-1.el7sat.noarch
    ruby193-rubygem-foreman_hooks-0.3.7-2.el7sat.noarch
    rubygem-hammer_cli_foreman-0.1.4.14-1.el7sat.noarch
    ruby193-rubygem-foreman_gutterball-0.0.1.9-1.el7sat.noarch
    foreman-selinux-1.7.2.13-1.el7sat.noarch
    foreman-postgresql-1.7.2.35-1.el7sat.noarch
    ruby193-rubygem-foreman_bootdisk-4.0.2.13-1.el7sat.noarch
    foreman-vmware-1.7.2.35-1.el7sat.noarch
    rubygem-hammer_cli_foreman_bootdisk-0.1.2.7-1.el7sat.noarch
    foreman-1.7.2.35-1.el7sat.noarch
    ruby193-rubygem-foreman-tasks-0.6.15.5-1.el7sat.noarch
    rubygem-hammer_cli_foreman_docker-0.0.3.9-1.el7sat.noarch
    dell-per805-01.rhts.eng.bos.redhat.com-foreman-client-1.0-1.noarch
    dell-per805-01.rhts.eng.bos.redhat.com-foreman-proxy-1.0-2.noarch

steps:
# hammer repository-set available-repositories --organization-id 1 --product-id 1 --name sat6_tools_repo
[Foreman] Username: admin
[Foreman] Password for admin: 
-----|------|---------|--------
NAME | ARCH | RELEASE | ENABLED
-----|------|---------|--------

# hammer repository-set available-repositories --organization-id 1 --product-id 2 --name puppet_repo
[Foreman] Username: admin
[Foreman] Password for admin: 
-----|------|---------|--------
NAME | ARCH | RELEASE | ENABLED
-----|------|---------|--------

Note You need to log in before you can comment on or make changes to this bug.