Bug 1247219 - perl-eperl-2.2.14-31.fc24 FTBFS: applying patches fails with rpm 4.12.90
perl-eperl-2.2.14-31.fc24 FTBFS: applying patches fails with rpm 4.12.90
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl-eperl (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Petr Šabata
Fedora Extras Quality Assurance
http://koji.fedoraproject.org/koji/ta...
:
Depends On: 1247248
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-27 10:56 EDT by Petr Pisar
Modified: 2015-07-28 05:01 EDT (History)
3 users (show)

See Also:
Fixed In Version: rpm-4.12.90-3.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-28 05:01:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Petr Pisar 2015-07-27 10:56:08 EDT
perl-eperl-2.2.14-31.fc24 fails to build in F24:

Patch #1 (perl-eperl-5.16compat.patch):
patching file eperl_perl5.h
Hunk #1 FAILED at 72.
1 out of 1 hunk FAILED -- saving rejects to file eperl_perl5.h.rej
RPM build errors:
+ echo 'Patch #1 (perl-eperl-5.16compat.patch):'
+ /usr/bin/patch -p1 --fuzz=0
error: Bad exit status from /var/tmp/rpm-tmp.hfJlKH (%prep)

Difference between working and failing build root:

        glibc 	2.21.90-18.fc24 	> 	2.21.90-19.fc24
	glibc-devel 	2.21.90-18.fc24 	> 	2.21.90-19.fc24
	glibc-common 	2.21.90-18.fc24 	> 	2.21.90-19.fc24
	glibc-headers 	2.21.90-18.fc24 	> 	2.21.90-19.fc24
	rpm-build 	4.12.0.1-18.fc24 	> 	4.12.90-1.fc24
	dnf-plugins-core 	0.1.9-1.fc23 	< 	
	rpm-libs 	4.12.0.1-18.fc24 	> 	4.12.90-1.fc24
	kernel-headers 	4.2.0-0.rc3.git2.1.... 	> 	4.2.0-0.rc3.git3.1....
	librepo 	1.7.16-2.fc23 	< 	
	hawkey 	0.5.9-2.fc24 	< 	
	python3-six 	1.9.0-3.fc23 	< 	
	bash-completion 	1:2.1-8.20150513git... 	< 	
	libreport-filesystem 	2.6.2-2.fc24 	< 	
	python3-pygpgme 	0.3-12.fc22 	< 	
	libcomps 	0.1.6-14.fc22 	< 	
	python3-dnf 	1.0.2-2.fc24 	< 	
	libsolv 	0.6.11-1.fc23 	< 	
	python3-libcomps 	0.1.6-14.fc22 	< 	
	rpm-python3 	4.12.0.1-18.fc24 	< 	
	gpgme 	1.4.3-6.fc23 	< 	
	rpm 	4.12.0.1-18.fc24 	> 	4.12.90-1.fc24
	rpm-build-libs 	4.12.0.1-18.fc24 	> 	4.12.90-1.fc24
	deltarpm 	3.6-10.fc23 	< 	
	python3-hawkey 	0.5.9-2.fc24 	< 	
	rpm-plugin-systemd-inhibit 	4.12.0.1-18.fc24 	< 	
	libuser 	0.61-2.fc23 	> 	0.62-1.fc24
	python3-librepo 	1.7.16-2.fc23 	< 	
	rpm-plugin-selinux 	4.12.0.1-18.fc24 	> 	4.12.90-1.fc24
	dnf-conf 	1.0.2-2.fc24 	< 	
	python3-iniparse 	0.4-16.fc23 	< 	
	python3-dnf-plugins-core 	0.1.9-1.fc23 	< 	

This is caused by upgrading rpm-build from 4.12.0.1-18.fc24 to 4.12.90-1.fc24.
Comment 1 Petr Šabata 2015-07-28 05:01:14 EDT
Fixed in rpm-4.12.90-3.fc24.

Note You need to log in before you can comment on or make changes to this bug.