Bug 1247222 - Error Field 'eventful+' not recognized for searching!
Error Field 'eventful+' not recognized for searching!
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Uncategorized (Show other bugs)
6.0.8
All Linux
medium Severity medium (vote)
: GA
: --
Assigned To: Walden Raines
http://projects.theforeman.org/issues...
: Triaged
: 1221530 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-27 11:02 EDT by hmiles
Modified: 2016-07-27 07:29 EDT (History)
7 users (show)

See Also:
Fixed In Version: rubygem-bastion-3.2.0.3-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 07:29:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 14243 None None None 2016-04-26 13:07 EDT

  None (edit)
Description hmiles 2015-07-27 11:02:24 EDT
Description of problem:

Error Field 'eventful+' not recognized for searching! when navigating to Monitor -> Reports from a Katello page.

This issue is also in Satellite 6.1 Beta.

  If you start at a Katello page 

    Content -> Products (https://fqdn/products)

  This url is used when I click on Monitor -> Reports

    https://fqdn/reports?search=eventful%2B%3D%2Btrue

  If I start at a Forman page.

    Monitor -> Dashboard (https://fqdn/dashboard)

  This url is used when I click on Monitor -> Reports

    https://FQDN/reports?search=eventful+%3D+true



Version-Release number of selected component (if applicable):
6.0.8
6.1 Beta

How reproducible:
Always

Steps to Reproduce:

  If you start at a Katello page 

    Content -> Products (https://fqdn/products)

  This url is used when I click on Monitor -> Reports

    https://fqdn/reports?search=eventful%2B%3D%2Btrue

  If I start at a Foreman page.

    Monitor -> Dashboard (https://fqdn/dashboard)

  This url is used when I click on Monitor -> Reports

    https://FQDN/reports?search=eventful+%3D+true

Actual results:
Error Field 'eventful+' not recognized for searching!

Expected results:
Reports page to load

Additional info:
http://projects.theforeman.org/issues/10155
Comment 1 hmiles 2015-07-27 11:03:07 EDT
More details on the error:

Oops, we're sorry but something went wrong
 
Field 'eventful+' not recognized for searching!

If you feel this is an error with Satellite 6 itself, please open a new issue with Satellite ticketing system, You would probably need to attach the Full trace and relevant log entries.
ScopedSearch::QueryNotSupported
Field 'eventful+' not recognized for searching!
app/controllers/reports_controller.rb:8:in `index'
app/models/concerns/foreman/thread_session.rb:33:in `clear_thread'
lib/middleware/catch_json_parse_errors.rb:9:in `call'
Comment 6 Walden Raines 2016-03-16 15:51:52 EDT
Created redmine issue http://projects.theforeman.org/issues/14243 from this bug
Comment 7 Bryan Kearney 2016-03-16 16:06:53 EDT
Upstream bug component is Uncategorized
Comment 8 Walden Raines 2016-03-18 12:11:55 EDT
PR - https://github.com/Katello/bastion/pull/105
Comment 9 Brad Buckingham 2016-03-21 09:14:00 EDT
*** Bug 1221530 has been marked as a duplicate of this bug. ***
Comment 10 Adam Ruzicka 2016-03-23 06:37:29 EDT
Moving to POST since upstream bug http://projects.theforeman.org/issues/14243 has been closed
-------------
Walden Raines
Applied in changeset commit:bastion|0f5eca89d38f6de49b71a618fff063e69c4b4aee.
Comment 11 Bryan Kearney 2016-05-26 15:52:33 EDT
Verified:
Version Verified: satellite-6.2.0-13.0.el7sat.noarch (snap 13.1)
Steps to verify:

Went to Content->Products. Selected MOnitor -> Config Management
URL is https://192.168.121.136/config_reports?search=eventful+%3D+true
Page shows correct

Went to Monitor -> Dashboard. Selected MOnitor -> Config Management
URL is https://192.168.121.136/config_reports?search=eventful+%3D+true
Page shows correct.
Comment 12 Bryan Kearney 2016-07-27 07:29:58 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.