Bug 1247263 - No way to tell what Project you're logged into
No way to tell what Project you're logged into
Status: CLOSED DUPLICATE of bug 1240895
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity high
: ---
: 7.0 (Kilo)
Assigned To: Matthias Runge
Ido Ovadia
: Reopened, ZStream
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-27 12:30 EDT by Audra Cooper
Modified: 2015-08-12 04:58 EDT (History)
19 users (show)

See Also:
Fixed In Version: python-django-horizon-2015.1.0-11.el7ost
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-12 04:58:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Logged in as project user but not displaying name of project (45.24 KB, application/zip)
2015-07-27 12:30 EDT, Audra Cooper
no flags Details
This shows the diff between devstack and RHOSP (113.37 KB, application/zip)
2015-07-30 12:11 EDT, Audra Cooper
no flags Details
Jetstream 3.0.1 Horizen showing "current project" tab at top (77.07 KB, image/png)
2015-07-31 17:55 EDT, Wayne Allen
no flags Details
Horizon Screen Shot (18.49 KB, image/png)
2015-08-04 18:22 EDT, Kurt Hey
no flags Details

  None (edit)
Description Audra Cooper 2015-07-27 12:30:08 EDT
Created attachment 1056682 [details]
Logged in as project user but not displaying name of project

Description of problem:
When you log into a Project in Horizon as a User with only member privs, there is nothing on the page to indicate what Project you're logged into.  

Version-Release number of selected component (if applicable): 4.0


How reproducible:
Very

Steps to Reproduce:
1. In Horizon, create a Project and add a User with member privs to that project
2. Log out of Admin and log in as the newly created User.  

Actual results:
Unless the user you created somehow indicates what project you're viewing, there is no way to tell.  Is this a change from the last release.  See screen shot.

Expected results:
The Project name should be listed under Identity or somewhere on the screen.

Additional info:
Comment 3 Audra Cooper 2015-07-30 12:11:56 EDT
Created attachment 1057736 [details]
This shows the diff between devstack and RHOSP

The new attachment shows logging in as a project user (with only member privs) that is a member on two projects.  This will show what the login looks like on both on Devstack and RHOSP.  With Devstack you can see a dropdown list of projects, with RHOSP you don't know what project you're logged in as.
Comment 4 Wayne Allen 2015-07-31 17:55:54 EDT
Created attachment 1058166 [details]
Jetstream 3.0.1 Horizen showing "current project" tab at top

To augment Audra's info, here is Jetstream 3.0.1 Horizon showing the "current project" tab at the top, which displays the currently selected project and can be used to select other available projects.
Comment 5 Wayne Allen 2015-07-31 17:58:04 EDT
To be clear, this tab does NOT appear in the current Red Hat horizon (Jetstream 4.0)
Comment 6 Matthias Runge 2015-08-04 10:49:23 EDT
this has been already fixed in rhbz#1240895

*** This bug has been marked as a duplicate of bug 1240895 ***
Comment 7 Kurt Hey 2015-08-04 18:22:40 EDT
Created attachment 1059258 [details]
Horizon Screen Shot
Comment 8 Kurt Hey 2015-08-04 18:24:17 EDT
Received a patch file from Mike Burns and deployed it against all three controllers.

Here are the steps we performed and the output after the patch:

1)	Copied the patch to the /tmp dir on all three controller nodes
2)	pcs resource disable horizon
3)	cd /usr/share/openstack-dashboard/
4)	patch –p1 < /tmp/<patchfile.patch>
5)	Repeated steps 3 and 4 on the other 2 controllers
6)	pcs resource enable horizon
7)	Logged into Horizon UI and created 2 projects and assigned a single user with _member privileges to the 2 projects.
8)	Logged out as admin and logged in as new user.

See screenshot.  The Projects tab is now visible but no projects show up in the list.  Looks like the patch enables it in Horizon but it is not getting populated by the backend.
Comment 10 Audra Cooper 2015-08-10 14:15:35 EDT
If additional debugging is needed on my environment where we see the bug, just send me an email, audra_cooper@dell.com.  I'm available anytime after UTC 11:00/EST 7:00 tomorrow, 8/11/15.
Comment 11 Matthias Runge 2015-08-12 04:58:52 EDT
A new package has been built to add the project selector.

Bug  https://bugzilla.redhat.com/show_bug.cgi?id=1236620 will be used to look into reasons, why the selector is empty.

*** This bug has been marked as a duplicate of bug 1240895 ***

Note You need to log in before you can comment on or make changes to this bug.