Bug 124735 - up2date fails on dev-3.3.12-1.i386.rpm with mknod error
Summary: up2date fails on dev-3.3.12-1.i386.rpm with mknod error
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: rpm   
(Show other bugs)
Version: 3.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Mike McLean
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-28 22:09 UTC by Chris Schamper
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-07-16 17:16:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
rpm -Uvv output for dev (29.46 KB, application/x-bzip2)
2004-06-01 13:12 UTC, Chris Schamper
no flags Details

Description Chris Schamper 2004-05-28 22:09:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030922

Description of problem:
May 28
coreutils-4.5.3-26
dev-3.3.8-1
dev-3.3.12-1


Virgin WS 3 install is unable to up2date. Up2date crashes on the dev
package with the following error:

-------------------
> up2date dev
 
Fetching package list for channel: rhel-i386-ws-3...
########################################
 
Fetching Obsoletes list for channel: rhel-i386-ws-3...
 
Fetching rpm headers...
########################################
 
Name                                    Version        Rel
----------------------------------------------------------
dev                                     3.3.12         1             
     i386                                                            
                    
 
 
Testing package set / solving RPM inter-dependencies...
########################################
dev-3.3.12-1.i386.rpm:      ########################## Done.
Preparing              ########################################### [100%]
 
Installing...
   1:dev                   
########################################### [100%]
There was a fatal RPM install error. The message was:
There was a rpm unpack error installing the package: dev-3.3.12-1

-------------------

Downloading the RPM does not help:

> md5sum dev-3.3.12-1.i386.rpm
bef3001b9f47f67e4cc4c48304d92df7  dev-3.3.12-1.i386.rpm

> rpm -Uvh dev-3.3.12-1.i386.rpm
Preparing...               
########################################### [100%]
   1:dev                   
########################################### [100%]
error: unpacking of archive failed on file
/dev/snd/controlC0;40b90782: cpio: mknod failed - No such file or
directory
-------------------

> ls -lh /bin/cpio
-rwxr-xr-x    1 root     root          51K Feb 14  2003 /bin/cpio

-------------------

> md5sum /bin/cpio
2d4ac6bff3509ac95a9500320a7766cf  /bin/cpio

-------------------

Suggestions?


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Install WS 3
2.su - (enter password)
3.up2date dev
    

Actual Results:  Unable to upgrade dev

Expected Results:  Able to upgrade dev

Additional info:

Comment 1 Tim Waugh 2004-05-28 22:51:57 UTC
The message:

/dev/snd/controlC0;40b90782: cpio: mknod failed - No such file or
directory

looks like the mknod() system call failed, not the mknod(1) command. 
Reassigning to cpio.

Comment 2 Jeff Johnson 2004-05-29 14:12:12 UTC
Hmmm, /dev/snd/* missing here too.

Reinstalling the dev package with --force appears to "fix".
Presumably mknod(2) has some check on permitted major/minor
and fails if not permitted, so the upgrade depends on what
kernel is running. That is entirely a guess ...

Reinstall the dev package with --force. If that doesn't fix,
please reopen this bug.

Comment 3 Chris Schamper 2004-06-01 12:42:40 UTC
># rpm -Uvh --force dev-3.3.12-1.i386.rpm
Preparing...               
########################################### [100%]
   1:dev                   
########################################### [100%]
error: unpacking of archive failed on file
/dev/snd/controlC0;40bdc981: cpio: mknod failed - No such file or
directory


Comment 4 Jeff Johnson 2004-06-01 12:52:24 UTC
Can you provide rpm -Uvv output please?

Comment 5 Chris Schamper 2004-06-01 13:12:37 UTC
Created attachment 100734 [details]
rpm -Uvv output for dev

This is the bzip2'd product of:
rpm -Uvv dev-3.3.12-1.i386.rpm

Comment 6 Chris Schamper 2004-06-01 13:15:42 UTC
Also seems this fellow also has / had the same issue
http://www.redhat.com/archives/redhat-list/2004-May/msg00586.html

There is more complaining in that post than detail, but it is a second
sighting none the less.

Thank you for the quick replies!

Comment 7 air_ogi 2004-06-03 22:03:41 UTC
I had the same problem on my Dell installed RHEL 3WS.
Dell installs ALSA, which links /dev/snd to /proc/asound/dev

Of course, doing mknod in /proc does not work.
I moved /dev/snd to /dev/snd.alsa, installed dev rpm and moved
snd.alsa back.

I am not sure if this is the same bug though.

Comment 8 Jeff Johnson 2004-06-04 13:34:12 UTC
Hmmm, if /dev/snd is a symlink, that would explain.

What does ls -l /dev/snd say? If not a directory, then
remove (or rename) and try rpm -Uvv dev-*.rpm again.

Comment 9 Chris Schamper 2004-07-16 17:15:29 UTC
The problem was exactly that there was a symlink. The method from
comment #7 fixes the bug.


Note You need to log in before you can comment on or make changes to this bug.