Bug 124736 - OO Writer erratic after opening word file with mathtype equations
OO Writer erratic after opening word file with mathtype equations
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-28 18:21 EDT by Tim Keitt
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: FC3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-15 04:05:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tim Keitt 2004-05-28 18:21:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040518 Firefox/0.8

Description of problem:
I'm trying to edit a word document in OO writer. The document has
embedded MathType 5.0 equations. These appear as graphic objects as
they should. However, when I delete them, it corrupts the document.
Hitting "undo" after deleting will cause character deletions in
unrelated parts of the document. It looks like the entire internal
structure of the document gets hosed. Deleting one equation will end
up deleting many paragraphs of text. I get weird overlapping
insertions and deletions. You get the idea. I'm sure this is a tricky
one to debug. MathType often screws up MS Word as well.

Version-Release number of selected component (if applicable):
openoffice.org-1.1.1-4

How reproducible:
Always

Steps to Reproduce:
1. Open MS Word document with embedded MathType 5 equations
2. Delete text in and around equations
3.
    

Actual Results:  Garbled document structure

Expected Results:  I just wish they would go a way.... :-0

Additional info:
Comment 1 Colin Charles 2004-06-14 13:10:17 EDT
Whole bunch of upstream MathType related bugs, one of which was:
http://qa.openoffice.org/issues/show_bug.cgi?id=24340

Supposed to be fixed in upstream 1.1.2 (at least the looping), so you
might want to give that a shot, to report back if it works - upstream
1.1.2 is currently in rc3, so you might want to give that a try to see
if it fixes the issue - if it does, report back here! Thanks.
Comment 2 Caolan McNamara 2004-09-10 04:59:19 EDT
caolan->Tim: Can you attach an example of such a word document which I
can play with to track the problem down ?
Comment 3 Tim Keitt 2004-09-10 10:10:14 EDT
Seems to work fine in the current version of oowriter. I'll upload a
document anyway. I don't remember if I fixed this version in word.
Oops. Too big to make an attachment. Can I email it to you?
Comment 4 Caolan McNamara 2004-09-14 03:21:13 EDT
Sure, mail it to me.
Comment 5 Caolan McNamara 2004-09-15 04:05:25 EDT
Received document and verified that it's ok now.

What I was concerned about was "tools->options->load/save->Microsoft
Office->load/save convert MathType to OpenOffice.org Math". And
checking if it was ok on both settings. But as you say it seems good
now in both settings with OpenOffice.org 1.1.2-3. I do recall fixing a
ole2 import resource leak which might have resulted in the dodgy
reported behaviour

Note You need to log in before you can comment on or make changes to this bug.