Bug 124746 - Name recognition of caos for the build of rpm.
Name recognition of caos for the build of rpm.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Mike McLean
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-28 22:52 EDT by Greg Kurtzer
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-29 09:50:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Greg Kurtzer 2004-05-28 22:52:25 EDT
--- rpm-4.3.1/configure.ac      2004-05-28 18:44:55.000000000 -0700
+++ rpm-4.3.1/configure.ac.new  2004-05-28 18:45:13.000000000 -0700
@@ -1126,6 +1126,7 @@
        test -f /etc/conectiva-release &&       RPMCANONVENDOR=conectiva
        test -f /etc/lvr-release &&             RPMCANONVENDOR=lvr
        test -f /etc/yellowdog-release &&       RPMCANONVENDOR=yellowdog
+        test -f /etc/caos-release &&            RPMCANONVENDOR=caos
        ;;
 esac
 RPMCANONOS="$build_os_noversion"
                                                                     
                                     
Pretty silly patch... Let me know if you need more. ;)
                                                                     
                                     
Thanks!
Comment 1 Jeff Johnson 2004-05-29 09:50:38 EDT
Perhaps silly, but "official" and trackable because you made
the report. E.g. it's now clear that "caos" rather than "cAos"
is desired.

Added in CVS, all of -r {rpm-4_2,rpm-4_3,HEAD) branches.

Note You need to log in before you can comment on or make changes to this bug.