Bug 1247488 - DIB fails on Invalid parameter force_power_state_during_sync
DIB fails on Invalid parameter force_power_state_during_sync
Status: CLOSED NOTABUG
Product: Red Hat OpenStack
Classification: Red Hat
Component: diskimage-builder (Show other bugs)
Director
Unspecified Unspecified
unspecified Severity unspecified
: ---
: Director
Assigned To: Ben Nemec
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-28 02:58 EDT by Adriano Petrich
Modified: 2016-04-18 02:51 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-28 07:14:31 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Undercloud install log (248.85 KB, text/plain)
2015-07-28 02:58 EDT, Adriano Petrich
no flags Details
/etc/puppet/manifests/puppet-stack-config.pp (10.95 KB, text/plain)
2015-07-28 03:00 EDT, Adriano Petrich
no flags Details

  None (edit)
Description Adriano Petrich 2015-07-28 02:58:26 EDT
Created attachment 1056937 [details]
Undercloud install log

Description of problem:
During undercloud install 
Command '['dib-run-parts', '/usr/libexec/os-refresh-config/configure.d']' returned non-zero exit status 1
the error that dib is complaining is 

Error: Invalid parameter force_power_state_during_sync on Class[Ironic::Conductor] at /etc/puppet/manifests/puppet-stack-config.pp:326 on node instack

Version-Release number of selected component (if applicable):


How reproducible:
Very

Steps to Reproduce:
1.do an openstack undercloud install

Actual results:
You get the 
Error: Invalid parameter force_power_state_during_sync on Class[Ironic::Conductor] at /etc/puppet/manifests/puppet-stack-config.pp:326 on node instack
followed by the 
Command '['dib-run-parts', '/usr/libexec/os-refresh-config/configure.d']' returned non-zero exit status 1
and the install fails

Expected results:
Undercloud installing

Additional info:
Comment 3 Adriano Petrich 2015-07-28 03:00:24 EDT
Created attachment 1056938 [details]
/etc/puppet/manifests/puppet-stack-config.pp
Comment 4 Attila Darazs 2015-07-28 07:02:10 EDT
Please stand by with this bug, we are probably not using the proper version of instack-undercloud due to gating problems.
Comment 5 Adriano Petrich 2015-07-28 07:14:31 EDT
mismatch between upstream instack being gated on downstream puddles.

Note You need to log in before you can comment on or make changes to this bug.