Bug 1247490 - [New HostSetupNetworks] bug in the error messages
[New HostSetupNetworks] bug in the error messages
Status: CLOSED CURRENTRELEASE
Product: ovirt-engine
Classification: oVirt
Component: General (Show other bugs)
---
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ovirt-3.6.0-rc
: 3.6.0
Assigned To: Alona Kaplan
Michael Burman
network
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-28 03:06 EDT by Alona Kaplan
Modified: 2016-02-10 14:16 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-04 08:35:34 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Network
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
rule-engine: ovirt‑3.6.0+
ylavi: Triaged+
ylavi: planning_ack+
rule-engine: devel_ack+
rule-engine: testing_ack+


Attachments (Terms of Use)
Explanations of the error messages (153.30 KB, text/plain)
2015-10-18 02:49 EDT, Alona Kaplan
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 45081 None None None Never
oVirt gerrit 46274 None None None Never

  None (edit)
Description Alona Kaplan 2015-07-28 03:06:40 EDT
Description of problem:
At lot of the can do action error messages of the new HostSetupNetworks command are to general. For example- 'The interface doesn't exist'. What interface?

Also, some of the messages have placeholders that are wrongly replaced. So the displayed message shows the '$placeHolder' instead of the desired value.

The following patch has comments with all the errors I found out-
https://gerrit.ovirt.org/#/c/42504

It was merged without fixing the comments since a lot of patches were on top of it.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 Michael Burman 2015-10-15 08:58:47 EDT
Hi Alona,

What should be tested here? which operations i should perform?
To which error messages i should expect? this report is very overall and there are a lot of Can do actions, i'm not sure what exactly to test here.

Thanks,
Comment 2 Alona Kaplan 2015-10-18 02:47:52 EDT
You have to play with the new HostSetupNetworks giving illegal input, making sure the error messages are correct and clear.

Most of the checks should be done via the rest since the ui blocks illegal operations.

List of the errors:
ACTION_TYPE_FAILED_HOST_NETWORK_QOS_NOT_SUPPORTED,
ACTION_TYPE_FAILED_HOST_NETWORK_QOS_NOT_SUPPORTED,
ACTION_TYPE_FAILED_HOST_NETWORK_QOS_INTERFACES_WITHOUT_QOS,
NETWORKS_ALREADY_ATTACHED_TO_IFACES,
NETWORK_CANNOT_DETACH_NETWORK_USED_BY_VMS,
NETWORK_BOND_RECORD_DOES_NOT_EXISTS,
BOND_USED_BY_NETWORK_ATTACHMENTS,
NETWORK_BOND_NAME_BAD_FORMAT,
NETWORK_BONDS_INVALID_SLAVE_COUNT,
NETWORK_INTERFACE_ALREADY_IN_BOND,
NETWORK_INTERFACE_REFERENCED_AS_A_SLAVE_MULTIPLE_TIMES,
NETWORK_INTERFACE_ADDED_TO_BOND_AND_NETWORK_IS_ATTACHED_TO_IT_AT_THE_SAME_TIME.
NETWORK_INTERFACE_ATTACHED_TO_NETWORK_CANNOT_BE_SLAVE,
NETWORK_ATTACHMENT_NOT_EXISTS,
NETWORK_ATTACHMENT_REFERENCES_NETWORK_INCOHERENTLY,
NETWORK_ATTACHMENT_REFERENCES_NICS_INCOHERENTLY,
BOND_REFERENCES_NICS_INCOHERENTLY,
NETWORK_ATTACHMENT_NOT_EXISTS,
NETWORK_ATTACHMENT_IN_BOTH_LISTS,
HOST_NETWORK_INTERFACE_NOT_EXIST,
NETWORK_ATTACHMENTS_NOT_EXISTS;
ACTION_TYPE_FAILED_CANNOT_REMOVE_LABELED_NETWORK_FROM_NIC,
ACTION_TYPE_FAILED_CANNOT_MOVE_LABELED_NETWORK_TO_ANOTHER_NIC,
NETWORK_SHOULD_BE_ATTACHED_VIA_LABEL_TO_ANOTHER_NIC,
ACTION_TYPE_FAILED_NETWORK_CUSTOM_PROPERTIES_NOT_SUPPORTED,
ACTION_TYPE_FAILED_NETWORK_CUSTOM_PROPERTIES_BAD_INPUT,
ATTACHMENT_REFERENCE_VLAN_DEVICE,
NIC_LABEL_REFERENCES_NICS_INCOHERENTLY,
INTERFACE_ON_NIC_LABEL_NOT_EXIST,
LABEL_NOT_EXIST_IN_HOST,
PARAMS_CONTAIN_DUPLICATE_LABELS,
LABEL_ATTACH_TO_IMPROPER_INTERFACE,
IMPROPER_BOND_IS_LABELED,
NETWORK_MTU_DIFFERENCES,
ACTION_TYPE_FAILED_NETWORK_ATTACHMENTS_REFERENCES_SAME_NETWORK_DUPLICATELY,
NETWORK_ATTACHMENT_NOT_EXISTS,
EXTERNAL_NETWORK_CANNOT_BE_PROVISIONED,
NETWORK_NOT_EXISTS_IN_CLUSTER,
NETWORK_ADDR_MANDATORY_IN_STATIC_IP,
ACTION_TYPE_FAILED_ROLE_NETWORK_HAS_NO_BOOT_PROTOCOL,
HOST_NETWORK_INTERFACE_NOT_EXIST,
ACTION_TYPE_FAILED_NETWORK_ADDRESS_CANNOT_BE_CHANGED,
CANNOT_CHANGE_ATTACHED_NETWORK,
NETWORK_ATTACH_ILLEGAL_GATEWAY,
NETWORK_ALREADY_ATTACHED_TO_HOST,
ACTION_TYPE_FAILED_HOST_NOT_EXIST,
ACTION_TYPE_FAILED_VDS_STATUS_ILLEGAL,
NETWORKS_NOT_IN_SYNC

I've attached an AppErrors.java file which contains explanation for each of the errors.
Comment 3 Alona Kaplan 2015-10-18 02:49 EDT
Created attachment 1084069 [details]
Explanations of the error messages
Comment 4 Michael Burman 2015-10-18 09:07:20 EDT
Verified on - 3.6.0.1-0.1.el6 

Tested several can do actions and their error messages.(As agreed with dev, there are too many)
Comment 5 Sandro Bonazzola 2015-11-04 08:35:34 EST
oVirt 3.6.0 has been released on November 4th, 2015 and should fix this issue.
If problems still persist, please open a new BZ and reference this one.

Note You need to log in before you can comment on or make changes to this bug.