Bug 1247496 - GUI quantity spinner increments the quantity of a instance based subscription on a host machine by multiple of 1
GUI quantity spinner increments the quantity of a instance based subscription...
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: subscription-manager (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: candlepin-bugs
John Sefler
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-28 03:25 EDT by Shwetha Kallesh
Modified: 2015-08-25 09:35 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-25 09:35:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
quantity incremented by spinner (223.97 KB, image/png)
2015-07-28 03:25 EDT, Shwetha Kallesh
no flags Details
Error dialogue when you try to attach quantity =1 of instance based subscription (255.65 KB, image/png)
2015-07-28 03:26 EDT, Shwetha Kallesh
no flags Details
Instance multiplier (252.18 KB, image/png)
2015-08-25 09:34 EDT, Shwetha Kallesh
no flags Details

  None (edit)
Description Shwetha Kallesh 2015-07-28 03:25:42 EDT
Created attachment 1056940 [details]
quantity incremented by spinner

Description of problem:
GUI quantity spinner increments the quantity of a instance based subscription on a host machine by 1 but should increment quantity by 2

Version-Release number of selected component (if applicable):
[root@dhcp35-236 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 2.0.6-1
subscription management rules: 5.16
subscription-manager: 1.15.9-2.el7
python-rhsm: 1.15.4-2.el7


How reproducible:


Steps to Reproduce:
1.subscription-manager-gui

2.In "All Available Subscriptions" tab , select a instance based subscription ----> try to increment the quantity of Instance based subscription 
3.

Actual results:
Spinner increments quantity in multiples of 1

Expected results:

Spinner should incremnt quantity by multiples of 2


Additional info:


[root@dhcp35-236 ~]# subscription-manager facts --list | grep "guest"
virt.is_guest: False
Comment 1 Shwetha Kallesh 2015-07-28 03:26:36 EDT
Created attachment 1056941 [details]
Error dialogue when you try to attach quantity =1 of instance based subscription
Comment 3 Devan Goodwin 2015-07-28 14:12:40 EDT
This is very likely caused by bug #1243146.
Comment 6 Shwetha Kallesh 2015-08-25 09:34:40 EDT
Created attachment 1066875 [details]
Instance multiplier

Closing bug as its working fine , instance multilpier is incremented by multiple of 2

[root@dhcp35-236 ~]# subscription-manager version
server type: Red Hat Subscription Management
subscription management server: 2.0.6-1
subscription management rules: 5.16
subscription-manager: 1.15.9-7.el7
python-rhsm: 1.15.4-3.el7

Note You need to log in before you can comment on or make changes to this bug.