Bug 1247566 - RFC build wireshark with libnl ver. 3 and disable airpcap
RFC build wireshark with libnl ver. 3 and disable airpcap
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: wireshark (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Hatina
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-28 06:48 EDT by Peter Lemenkov
Modified: 2016-05-31 21:33 EDT (History)
6 users (show)

See Also:
Fixed In Version: 1.12.7-2.fc23 wireshark-1.12.7-2.fc22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-03 23:24:43 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Lemenkov 2015-07-28 06:48:49 EDT
Hello Peter!
I've just found what AirPcap is - it looks like a some sort of a proprietary Windows-only hardware dongle for low level access to a Wireless network:

* https://www.cacetech.com/support/airpcap_faq.html#faq_12

Although it didn't make any troubles before, it does now (since v. 1.99.<something> it breaks building). This might be fixed soon but why bother at all if we cannot use it anyway?

Another one proposal is to add --with-libnl option instead. This adds building against libnl library available in Fedora (libnl3 works fine). This library also allows low-level access to a wifi network. Although I didn't test it yet.

The airpicap support was added by Jan Safranek in this commit:

e0d0dbd9c05ad15669c1da9c2bd21864d6e786f1

It looks like an accident. I've checked Debian and OpenSUSE - none of them uses --enable-airpcap during build.
Comment 1 Peter Lemenkov 2015-07-28 06:50:10 EDT
Jan, out of curiosity could you please remember what was the reason to enable airpcap?
Comment 2 Jan Safranek 2015-07-28 07:03:25 EDT
"Thu Jun  9 2011", that's a long time ago. I really don't remember why I enabled it, sorry. Indeed it looks like a mistake.
Comment 3 Fedora Update System 2015-08-21 15:27:06 EDT
wireshark-1.12.7-2.fc22 has been submitted as an update to Fedora 22. https://bugzilla.redhat.com/show_bug.cgi?id=1247566
Comment 4 Fedora Update System 2015-08-21 15:29:31 EDT
wireshark-1.12.7-2.fc23 has been submitted as an update to Fedora 23. https://bugzilla.redhat.com/show_bug.cgi?id=1247566
Comment 5 Fedora Update System 2015-08-21 22:50:45 EDT
wireshark-1.12.7-2.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update wireshark'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-13945
Comment 6 Fedora Update System 2015-08-22 12:23:59 EDT
wireshark-1.12.7-2.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.\nIf you want to test the update, you can install it with \n su -c 'yum --enablerepo=updates-testing update wireshark'. You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2015-13946
Comment 7 Fedora Update System 2015-09-03 23:24:19 EDT
wireshark-1.12.7-2.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2015-10-07 02:21:16 EDT
wireshark-1.12.7-2.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.