This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1247577 - Poedit does not find aspell packages / dictionaries
Poedit does not find aspell packages / dictionaries
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: poedit (Show other bugs)
22
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Haïkel Guémar
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-28 07:23 EDT by Tobias Schönberg
Modified: 2015-09-28 14:42 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-09-28 14:42:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tobias Schönberg 2015-07-28 07:23:43 EDT
Description of problem:

I am trying to localize a *.po file using Poedit. A message prompts me to install a dictionary for each language. The message directs me to this page (http://poedit.net/trac/wiki/Doc/SpellcheckerLinux?fromVersion=1.8.1) that says one should install a myspell-* or aspell-* dictionary. After installing e.g. aspell-it and reopening the file I get the same warning about the dictionary. This severely reduces the functionality of the program, because no translation suggestions are available.

Version of Poedit:

1.8.1

Reproduce:

Install e.g. aspell-de package and try localizing a de.po file. The warning will show up that says "Spellchecking is disabled, because the dictionary for German isn't installed.
Comment 1 c72578 2015-07-28 08:31:03 EDT
Have you tried installing hunspell-de?
Comment 2 Tobias Schönberg 2015-07-28 08:44:37 EDT
I tried installing hunspell-de. That makes the warning disappear, but the "translation suggestions" still don't work.
Comment 3 c72578 2015-07-29 12:08:28 EDT
OK. The "translation suggestions" is a separate topic. However ...

How many translations have you stored in your translation memory?
See: Edit - Preferences - TM
Are these translations in the TM from the associated language?
Comment 4 Tobias Schönberg 2015-07-29 13:27:35 EDT
Stored translations: 0

(It is a fresh install)

I am probably making a silly mistake.
Comment 5 c72578 2015-08-11 06:22:53 EDT
Not a bug, can be closed.

Note You need to log in before you can comment on or make changes to this bug.