Bug 1247645 - openstack undercloud install fails with Invalid parameter force_power_state_during_sync on Class[Ironic::Conductor]
openstack undercloud install fails with Invalid parameter force_power_state_d...
Status: CLOSED CURRENTRELEASE
Product: RDO
Classification: Community
Component: instack-undercloud (Show other bugs)
Kilo
x86_64 Unspecified
unspecified Severity unspecified
: ---
: Kilo
Assigned To: James Slagle
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-28 10:07 EDT by utpx
Modified: 2016-04-18 02:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-30 19:28:52 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description utpx 2015-07-28 10:07:52 EDT
Description of problem:

openstack undercloud install fails with error message:

Invalid parameter force_power_state_during_sync on Class[Ironic::Conductor]

in /usr/libexec/os-refresh-config/configure.d/50-puppet-stack-config

Version-Release number of selected component (if applicable):

 - CentOS Linux release 7.1.1503 (Core) 3.10.0-229.7.2.el7.x86_64

 - instack-undercloud-2.1.3-dev83.el7.centos.noarch

How reproducible: always

Steps to Reproduce:
1. https://repos.fedorapeople.org/repos/openstack-m/docs/master/installation/installing.html
2. yum install -y https://rdoproject.org/repos/openstack-kilo/rdo-release-kilo.rp
3. curl -o /etc/yum.repos.d/rdo-management-trunk.repo.new http://trunk-mgt.rdoproject.org/centos-kilo/current/delorean-rdo-management.repo
4. openstack undercloud install

Actual results:

2015-07-28 13:44:19,014 INFO: dib-run-parts Tue Jul 28 13:44:19 CEST 2015 Running /usr/libexec/os-refresh-config/configure.d/50-puppet-stack-config
2015-07-28 13:44:19,024 INFO: + set -o pipefail
2015-07-28 13:44:19,024 INFO: + set +e
2015-07-28 13:44:19,024 INFO: + puppet apply --detailed-exitcodes /etc/puppet/manifests/puppet-stack-config.pp
2015-07-28 13:44:24,868 INFO: ESC[1;31mWarning: You cannot collect without storeconfigs being set on line 253 in file /etc/puppet/manifests/puppet-stack-config.ppESC[0m
2015-07-28 13:44:24,870 INFO: ESC[1;31mWarning: You cannot collect without storeconfigs being set on line 257 in file /etc/puppet/manifests/puppet-stack-config.ppESC[0m
2015-07-28 13:44:24,870 INFO: ESC[1;31mWarning: You cannot collect without storeconfigs being set on line 261 in file /etc/puppet/manifests/puppet-stack-config.ppESC[0m
2015-07-28 13:44:29,008 INFO: ESC[1;31mWarning: Scope(Class[Glance::Api]): The auth_host parameter is deprecated. Please use auth_uri and identity_uri instead.ESC[0m
2015-07-28 13:44:29,009 INFO: ESC[1;31mWarning: Scope(Class[Glance::Api]): The auth_port parameter is deprecated. Please use auth_uri and identity_uri instead.ESC[0m
2015-07-28 13:44:29,011 INFO: ESC[1;31mWarning: Scope(Class[Glance::Api]): The auth_protocol parameter is deprecated. Please use auth_uri and identity_uri instead.ESC[0m
2015-07-28 13:44:29,144 INFO: ESC[1;31mWarning: Scope(Class[Glance::Registry]): The auth_host parameter is deprecated. Please use auth_uri and identity_uri instead.ESC[0m
2015-07-28 13:44:29,145 INFO: ESC[1;31mWarning: Scope(Class[Glance::Registry]): The auth_port parameter is deprecated. Please use auth_uri and identity_uri instead.ESC[0m
2015-07-28 13:44:29,145 INFO: ESC[1;31mWarning: Scope(Class[Glance::Registry]): The auth_protocol parameter is deprecated. Please use auth_uri and identity_uri instead.ESC[0m
2015-07-28 13:44:29,446 INFO: ESC[1;31mWarning: Scope(Class[Nova::Api]): The auth_host parameter is deprecated. Please use auth_uri and identity_uri instead.ESC[0m
2015-07-28 13:44:29,447 INFO: ESC[1;31mWarning: Scope(Class[Nova::Api]): The auth_port parameter is deprecated. Please use auth_uri and identity_uri instead.ESC[0m
2015-07-28 13:44:29,447 INFO: ESC[1;31mWarning: Scope(Class[Nova::Api]): The auth_protocol parameter is deprecated. Please use auth_uri and identity_uri instead.ESC[0m
2015-07-28 13:44:29,498 INFO: ESC[1;31mWarning: Scope(Class[Nova::Vncproxy::Common]): Could not look up qualified variable '::nova::compute::vncproxy_host'; class ::nova::compute has not been evaluatedESC[0m
2015-07-28 13:44:29,499 INFO: ESC[1;31mWarning: Scope(Class[Nova::Vncproxy::Common]): Could not look up qualified variable '::nova::compute::vncproxy_protocol'; class ::nova::compute has not been evaluatedESC[0m
2015-07-28 13:44:29,499 INFO: ESC[1;31mWarning: Scope(Class[Nova::Vncproxy::Common]): Could not look up qualified variable '::nova::compute::vncproxy_port'; class ::nova::compute has not been evaluatedESC[0m
2015-07-28 13:44:29,499 INFO: ESC[1;31mWarning: Scope(Class[Nova::Vncproxy::Common]): Could not look up qualified variable '::nova::compute::vncproxy_path'; class ::nova::compute has not been evaluatedESC[0m
2015-07-28 13:44:29,702 INFO: ESC[1;31mWarning: Scope(Class[Neutron::Server]): The auth_host parameter is deprecated. Please use auth_uri and identity_uri instead.ESC[0m
2015-07-28 13:44:29,702 INFO: ESC[1;31mWarning: Scope(Class[Neutron::Server]): The auth_port parameter is deprecated. Please use auth_uri and identity_uri instead.ESC[0m
2015-07-28 13:44:29,704 INFO: ESC[1;31mWarning: Scope(Class[Neutron::Server]): The auth_protocol parameter is deprecated. Please use auth_uri and identity_uri instead.ESC[0m
2015-07-28 13:44:30,289 INFO: ESC[1;31mWarning: Scope(Class[Concat::Setup]): concat::setup is deprecated as a public API of the concat module and should no longer be directly included in the manifest.ESC[0m
2015-07-28 13:44:30,579 INFO: ESC[1;31mWarning: Scope(Class[Swift::Proxy::Authtoken]): The auth_host parameter is deprecated. Please use auth_uri and identity_uri instead.ESC[0m
2015-07-28 13:44:30,580 INFO: ESC[1;31mWarning: Scope(Class[Swift::Proxy::Authtoken]): The auth_port parameter is deprecated. Please use auth_uri and identity_uri instead.ESC[0m
2015-07-28 13:44:30,580 INFO: ESC[1;31mWarning: Scope(Class[Swift::Proxy::Authtoken]): The auth_protocol parameter is deprecated. Please use auth_uri and identity_uri instead.ESC[0m
2015-07-28 13:44:30,969 INFO: ESC[1;31mWarning: Scope(Class[Ceilometer::Api]): The keystone_host parameter is deprecated. Please use auth_uri and identity_uri instead.ESC[0m
2015-07-28 13:44:30,970 INFO: ESC[1;31mWarning: Scope(Class[Ceilometer::Api]): The keystone_port parameter is deprecated. Please use auth_uri and identity_uri instead.ESC[0m
2015-07-28 13:44:30,970 INFO: ESC[1;31mWarning: Scope(Class[Ceilometer::Api]): The keystone_protocol parameter is deprecated. Please use auth_uri and identity_uri instead.ESC[0m
2015-07-28 13:44:31,192 INFO: ESC[1;31mWarning: Scope(Class[Heat]): The keystone_host parameter is deprecated. Please use auth_uri and identity_uri instead.ESC[0m
2015-07-28 13:44:31,193 INFO: ESC[1;31mWarning: Scope(Class[Heat]): The keystone_port parameter is deprecated. Please use auth_uri and identity_uri instead.ESC[0m
2015-07-28 13:44:31,194 INFO: ESC[1;31mWarning: Scope(Class[Heat]): The keystone_protocol parameter is deprecated. Please use auth_uri and identity_uri instead.ESC[0m
2015-07-28 13:44:31,579 INFO: ESC[1;31mError: Invalid parameter force_power_state_during_sync on Class[Ironic::Conductor] at /etc/puppet/manifests/puppet-stack-config.pp:326 on node os-undercloud-01.eecsit.tu-berlin.de
2015-07-28 13:44:31,580 INFO: Wrapped exception:
2015-07-28 13:44:31,580 INFO: Invalid parameter force_power_state_during_syncESC[0m
2015-07-28 13:44:31,580 INFO: ESC[1;31mError: Invalid parameter force_power_state_during_sync on Class[Ironic::Conductor] at /etc/puppet/manifests/puppet-stack-config.pp:326 on node os-undercloud-01.eecsit.tu-berlin.deESC[0m
2015-07-28 13:44:31,656 INFO: + rc=1
2015-07-28 13:44:31,657 INFO: + set -e
2015-07-28 13:44:31,657 INFO: + echo 'puppet apply exited with exit code 1'
2015-07-28 13:44:31,657 INFO: puppet apply exited with exit code 1
2015-07-28 13:44:31,657 INFO: + '[' 1 '!=' 2 -a 1 '!=' 0 ']'
2015-07-28 13:44:31,657 INFO: + exit 1
2015-07-28 13:44:31,660 INFO: [2015-07-28 13:44:31,658] (os-refresh-config) [ERROR] during configure phase. [Command '['dib-run-parts', '/usr/libexec/os-refresh-config/configure.d']' returned non-zero exit status 1]
2015-07-28 13:44:31,660 INFO: 
2015-07-28 13:44:31,660 INFO: [2015-07-28 13:44:31,659] (os-refresh-config) [ERROR] Aborting...

Expected results:

instack-install-undercloud complete.

Additional info:
Comment 1 John Trowbridge 2015-07-30 14:23:12 EDT
This was caused by a mismatch between the version of instack-undercloud and openstack-puppet-modules.

This is fixed with openstack-puppet-modules-2015.1.9-3
Comment 2 Alan Pevec 2015-07-30 19:28:52 EDT
Published in RDO Kilo production repository:
http://rdoproject.org/repos/openstack-kilo/el7/openstack-puppet-modules-2015.1.9-3.el7.noarch.rpm

Note You need to log in before you can comment on or make changes to this bug.