Bug 1247740 - turbostat in cpupowerutils does not show C-states for Haswell processor
turbostat in cpupowerutils does not show C-states for Haswell processor
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: cpupowerutils (Show other bugs)
6.7
x86_64 Linux
unspecified Severity medium
: rc
: ---
Assigned To: Neil Horman
Erik Hamera
:
: 1256707 (view as bug list)
Depends On:
Blocks: 1172231
  Show dependency treegraph
 
Reported: 2015-07-28 13:55 EDT by Matthew Whitehead
Modified: 2015-08-28 13:43 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-08-18 16:19:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Whitehead 2015-07-28 13:55:44 EDT
Description of problem: turbostat does not show C-states in on Haswell processors using upgraded (1.2-7) cpupowerutils package under RHEL6.7.


Version-Release number of selected component (if applicable): version 1.2-5 works on Haswell, version 1.2-7 does not work.


How reproducible: 100%


Steps to Reproduce:
1. run 'turbostat' version 1.2-7 on Haswell processor. It will not show C-state information.

Actual results:
Does not report C-state info.

Expected results:
Should report C-state info.

Additional info:

This code (turbostat.c) probably should probably be looked at first:

do_nhm_platform_info = do_nhm_cstates = do_smi = probe_nhm_msrs(family, model);
Comment 2 Neil Horman 2015-07-28 16:25:38 EDT
way to close to the end of 6.7 for this, needs to wait for 6.8
Comment 3 Eric Hagberg 2015-07-29 13:24:14 EDT
But this is a regression - shouldn't this get fixed sooner?
Comment 4 Eric Hagberg 2015-07-30 13:22:01 EDT
Ivybridge is also broken (Intel(R) Xeon(R) CPU E7-4860 v2 @ 2.60GHz).

Here's what I get with 1.2-5:

pk cor CPU    %c0  GHz  TSC SMI    %c1    %c3    %c6    %c7 CTMP PTMP   %pc2   %pc3   %pc6   %pc7  Pkg_W  Cor_W RAM_W PKG_% RAM_%
             0.14 1.55 2.60   0   0.50   0.01  99.35   0.00   45   49  45.70   0.00  24.97   0.00  82.32  25.36 42.88  0.00  0.00
 0   0   0   0.95 1.27 2.60   0   1.40   0.05  97.59   0.00   38   49  45.14   0.00  24.99   0.00  20.87   6.59 11.12  0.00  0.00
 0   0  48   0.05 1.26 2.60   0   2.31
 0   1   4   0.09 1.23 2.60   0   2.16   0.06  97.68   0.00   42
 0   1  52   1.02 1.23 2.60   0   1.24
 0   2   8   0.04 1.22 2.60   0   0.22   0.01  99.73   0.00   38
 0   2  56   0.02 1.20 2.60   0   0.24
(...snip...)

and here's 1.2-7:

     CPU Avg_MHz   %Busy Bzy_MHz TSC_MHz
       -       1    0.06    1415    2600
       0       8    0.60    1338    2601
      48       2    0.18    1219    2601
       4       2    0.13    1211    2601
      52       1    0.04    1256    2601
       8       1    0.05    1211    2601
      56       1    0.04    1204    2601
      12       5    0.26    1804    2601
(...snip...)
Comment 5 Jeremy Eder 2015-07-30 13:34:25 EDT
turbostat was rebased to latest upstream, which includes this patch:

https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/tools/power/x86/turbostat/turbostat.c?id=1cc21f7b6b747220c29b42cfd1c84b5648d12407

Use --debug to get the old output formatting back.
Comment 9 Neil Horman 2015-07-31 15:54:37 EDT
Well, I certainly didn't expect this change, but I actually can see his reasoning.  If there is an expectation of more c-states than can be visually interpreted reasonably on a console, then it makes sense to hide them, as showing them doesn't do any good anyway.  If you want to provide a filter so that you can only see the c-states that might interest you, that makes good sense, but such functionality already exists with:

turbostat --debug | awk '/regex for rows/ { print $interestingc-state}'

So you don't really need to re-invent that wheel.


I presume adding --debug does in fact bring the c-state output back in RHEL6?
Comment 10 Eric Hagberg 2015-07-31 16:39:59 EDT
Adding "--debug" does bring the c-state output back.
Comment 11 Matthew Whitehead 2015-08-18 15:26:38 EDT
The '--debug' does revert to the old behavior and is being used as a workaround by my customer.
Comment 12 Neil Horman 2015-08-18 16:19:04 EDT
In that case this is NOTABUG
Comment 13 Jeremy Eder 2015-08-25 06:48:27 EDT
*** Bug 1256707 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.