Bug 124785 - kernel acpi code has os name "Linux" which is poor for compatability
kernel acpi code has os name "Linux" which is poor for compatability
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-29 20:46 EDT by cam
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-09 06:01:29 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description cam 2004-05-29 20:46:48 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8a2)
Gecko/20040521

Description of problem:
There is a kernel patch to:
include/acpi/platform/aclinux.h

To change the OS name passed to the ACPI code
#define ACPI_OS_NAME                "Linux"

The patch changes the name to "Microsoft Windows XP" because that is
detected by many BIOSes.

Adopting this change would improve the compatability of the kernel
with laptops / notebooks. The upstream ACPI code will probably have
this change.

Version-Release number of selected component (if applicable):
kernel-2.6.6-1.397

How reproducible:
Always

Steps to Reproduce:
1. use a recent binary kernel
2. 
3.
    

Actual Results:  see unreliable ACPI behaviour

Expected Results:  proper ACPI behaviour

Additional info:

A workaround is to pass the acpi_os_name="Microsoft Windows XP" at
boot time
Comment 1 Arjan van de Ven 2004-05-30 07:09:59 EDT
Interesting idea; I'll try it for a few builds to see how it goes
Comment 2 Arjan van de Ven 2004-06-09 06:01:29 EDT
seems to work ok enough ;)

Note You need to log in before you can comment on or make changes to this bug.