Bug 1247881 - ld/12942 test fails on s390x
ld/12942 test fails on s390x
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: binutils (Show other bugs)
7.2
s390x Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Jeff Law
qe-baseos-tools
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-29 03:24 EDT by Miloš Prchlík
Modified: 2015-07-29 13:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-29 13:32:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Miloš Prchlík 2015-07-29 03:24:39 EDT
Description of problem:


Upstream test case ld/12942 fails on s390x:

g++ -B/root/rpmbuild/BUILD/binutils-2.23.52.0.1/ld/testsuite/tmpdir/gas/ -B/root/rpmbuild/BUILD/binutils-2.23.52.0.1/ld/testsuite/tmpdir/ld/ -Wl,-z,norelro -O2 -flto -fuse-linker-plugin tmpdir/pr12942b.o tmpdir/pr12942a.o
pid is 16547 16549 -16547 -16549
close result is child process exited abnormally
output is tmpdir/pr12942b.o: In function `test()':
pr12942b.cc:(.text._Z4testv[_Z4testv]+0x24): undefined reference to `link_error()'
collect2: error: ld returned 1 exit status
 status 1
tmpdir/pr12942b.o: In function `test()':
pr12942b.cc:(.text._Z4testv[_Z4testv]+0x24): undefined reference to `link_error()'
collect2: error: ld returned 1 exit status
FAIL: PR ld/12942 (3)


Version-Release number of selected component (if applicable):

binutils-2.23.52.0.1-50.el7


How reproducible:


Steps to Reproduce:
1. run ld testsuite, e.g. by rebuilding the whole package (rpmbuild --recompile $srpm)
2.
3.


Actual results:


Expected results:


Additional info:
Comment 1 Jeff Law 2015-07-29 13:32:13 EDT
This has to be a problem on the QE side since those tests passed without any issues during the RPM build:

http://download.devel.redhat.com/brewroot/packages/binutils/2.23.52.0.1/51.el7/data/logs/s390x/build.log


[ ... ]
PASS: Build libdummy.a PR ld/12942 (1)
PASS: Build libdummy.a PR ld/12942 (2)
[ ... ]
PASS: PR ld/12942 (3)
[ ... ]
PASS: PR ld/12942 (1)
PASS: PR ld/12942 (2)

And the summary for ld:

		=== ld Summary ===
# of expected passes		761
# of unexpected successes	7
# of expected failures		22
# of untested testcases		1

Note there are no unexpected failures.  The logs for 50.el7 are the same.

Note You need to log in before you can comment on or make changes to this bug.