Bug 124794 - backspace key does not work from Exceed
backspace key does not work from Exceed
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: xterm (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-30 04:17 EDT by Nils Hammar
Modified: 2009-01-13 00:15 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-11 08:24:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nils Hammar 2004-05-30 04:17:56 EDT
Description of problem:
The backspace key does not work when using xterm from an Exceed
X-terminal emulator. It behaves identically to the "Delete" key and
sends the same keycode.

This behaviour is located to the file /usr/lib/X11/app-defaults/XTerm
where deletion of the line "...<Key>Delete:..." resolves the problem.

A quick test reveals no immediate problem using xterm on the server
console after modifying this file.

Version-Release number of selected component (if applicable):
xterm-179-6.EL

How reproducible:
Always

Steps to Reproduce:
1. Use a PC with Exceed 8 installed.
2. Open a xterm window to the Fedora server.
3. Enter something and then try to erase the info with the BS key
(Left arrow above "Enter").


Actual Results:  No characters deleted, and a "bell" sounded.

Expected Results:  Character left of cursor to be erased.

Additional info: This seems to be a portability issue.
Comment 1 Mike A. Harris 2004-06-01 17:11:08 EDT
If I recall correctly, this is just a difference in the way that the
defaults that Exceed expects do not match the default xterm provides.
I have not ever used Exceed and do not have access to it, however
you should be able to change settings in Exceed to match what xterm
uses in all other UNIX like environments, or you can change the
TERM variable to the terminal type Exceed expects.  That might
get you a working setup.  Again however, this is just a suggestion
that I've got no way to confirm, as I do not have access to that
software.

I have carbon copied the upstream xterm author as he may be aware
of any Exceed related issues and would be better suited to advise.
I'm not aware of any bugs in xterm itself that cause problems in
Exceed however.

Comment 2 Thomas E. Dickey 2004-06-01 19:20:36 EDT
Google suggests this for further reading:
http://web.purplefrog.com/~thoth/philosophy/backspace-delete.html

He's talking about this line in the XTerm app-defaults file:
*VT100.translations:   #override \ 
        <Key>Delete:    string(0x1b) string("[3~")  \n\
which I recall as one of the reasons for reinstalling that file.
Comment 3 Thomas E. Dickey 2004-06-01 19:28:50 EDT
On the other hand (peculiarities of Exceed), this is interesting:
http://www.nedit.org/pipermail/discuss/2001-October/000369.html
Comment 4 Nils Hammar 2004-06-02 00:47:51 EDT
Comment #2 reflects my problem very well, and I tried to fiddle around
a lot with Exceed before figuring out that the translate-statement in
the Xterm config file was messing up everything. I don't have any pure
X terminal, so I'm not able to check with anything else. The best
solution would be to drop that offending line in the config file.

Changing the TERM variable doesn't change a thing, or even makes
things worse with other side-effects.

Comment 5 Thomas E. Dickey 2004-06-02 17:29:37 EDT
That's pretty much what I see.  (I'm very pressed for time til
Friday, will probably retest the Redhat app-defaults file to
retest that - I only recall that it seemed to interfere with
more than the "Delete" on the 6-key editing-keypad).
Comment 6 Mike A. Harris 2005-04-11 08:24:21 EDT
We've updated our xterm resources patch in rawhide xterm.  Please upgrade
to the latest rawhide xterm.  If the problem persists, it is suggested
that you try reconfiguring things on the Exceed side of things.

Setting status to RAWHIDE.

Note You need to log in before you can comment on or make changes to this bug.