Bug 124798 - rpm 4.3.1 requires LD_ASSUME_KERNEL=2.4.19 on FC1
Summary: rpm 4.3.1 requires LD_ASSUME_KERNEL=2.4.19 on FC1
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm   
(Show other bugs)
Version: 2
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: Mike McLean
URL: https://www.redhat.com/mailman/privat...
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-05-30 10:33 UTC by Axel Thimm
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-05-30 14:45:24 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Axel Thimm 2004-05-30 10:33:55 UTC
Description of problem:
I am trying to get rpm 4.3.1 running on FC1. The build (based on FC2'
src.rpm) completes OK, but upgrading to the built rpm gives:

# rpm -q rpm
rpmdb: Berkeley DB library configured to support only DB_PRIVATE
environments
error: db4 error(22) from dbenv->open: Invalid argument
error: cannot open Packages index using db3 - Invalid argument (22)
error: cannot open Packages database in /var/lib/rpm
package rpm is not installed

# LD_ASSUME_KERNEL=2.4.19 rpm -q rpm
rpm-4.3.1-0.3_23.rhfc1.at

I tried with and without posixmutexes.

Version-Release number of selected component (if applicable):
4.3.1

How reproducible:
always

Steps to Reproduce:
1.rebuild src.rpm from FC2
2.install new rpm rpms
3.Try to use rpm in any operation

Comment 1 Jeff Johnson 2004-05-30 14:45:24 UTC
You are encountering the O_DIRECT failure opening
a dbenv.

Which means you have misbuilt rpm somehow. db-4.2.52
disables O_DIRECT if built in the correct environment,
see the configure spew.


Note You need to log in before you can comment on or make changes to this bug.