Bug 1247982 - ceilometer kafka publisher requires kafka-python library
ceilometer kafka publisher requires kafka-python library
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-kafka (Show other bugs)
7.0 (Kilo)
Unspecified Linux
medium Severity high
: z3
: 7.0 (Kilo)
Assigned To: Pradeep Kilambi
Yurii Prokulevych
: FutureFeature, ZStream
Depends On: 1282912
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-29 07:41 EDT by Alfredo Moralejo
Modified: 2018-02-08 05:47 EST (History)
11 users (show)

See Also:
Fixed In Version: python-kafka-0.9.4-1.el7ost
Doc Type: Enhancement
Doc Text:
The kafka-python library is now included in this release (provided by the python-kafka package). This library provides support for Apache Kafka; this, in turn, allows the Telemetry service to dispatch events and samples with the Kafka publisher.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-21 12:12:26 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alfredo Moralejo 2015-07-29 07:41:33 EDT
Description of problem:

New kafka publisher requires kafka-python library kafka-python>=0.9.2, however the library does not appear to be in the OSP7 beta repositories, so if fails when the publisher is added to a sink.

Version-Release number of selected component (if applicable):


How reproducible:

Always

Steps to Reproduce:

Try to configure a kafka sink

Actual results:

An error is displayed in ceilometer logs

Expected results:

kafka should be properly working

Additional info:
Comment 13 errata-xmlrpc 2015-12-21 12:12:26 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2015:2678

Note You need to log in before you can comment on or make changes to this bug.