Bug 1248027 - [RHGS] Repo failures in RHS 3.0 AMIs
[RHGS] Repo failures in RHS 3.0 AMIs
Status: CLOSED CURRENTRELEASE
Product: Red Hat Update Infrastructure for Cloud Providers
Classification: Red Hat
Component: Operations (Show other bugs)
3.0.0
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: dgao
Martin Minar
:
Depends On:
Blocks: 1190574
  Show dependency treegraph
 
Reported: 2015-07-29 09:11 EDT by Anush Shetty
Modified: 2016-07-03 20:58 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-07 11:06:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Reproducer screen log (2.04 KB, text/plain)
2015-08-14 08:14 EDT, mkovacik
no flags Details
Verifying screen log (16.87 KB, text/plain)
2015-08-14 08:21 EDT, mkovacik
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 1556793 None None None Never

  None (edit)
Description Anush Shetty 2015-07-29 09:11:55 EDT
Description of problem: We see authorization errors with RHS 3.0 RHUI repos on RHS AMIs: RHEL-6.5-RHS-3.0-20141219-x86_64-9-Access2-GP2 - ami-b560f7c2


Version-Release number of selected component (if applicable): RHEL-6.5-RHS-3.0-20141219-x86_64-9-Access2-GP2 - ami-b560f7c2


How reproducible: Consistent


Steps to Reproduce:
1. yum update -y

Actual results:


 yum update -y
Loaded plugins: aliases, amazon-id, changelog, downloadonly, fastestmirror, filter-data, keys, list-data, merge-conf, priorities, protectbase, rhui-lb, security, tmprepo, tsflags,
              : upgrade-helper, verify, versionlock
Loading mirror speeds from cached hostfile
 * rhui-REGION-client-config-server-6: rhui2-cds02.eu-west-1.aws.ce.redhat.com
 * rhui-REGION-client-config-server-6-rhs: rhui2-cds02.eu-west-1.aws.ce.redhat.com
 * rhui-REGION-rhel-server-releases: rhui2-cds02.eu-west-1.aws.ce.redhat.com
 * rhui-REGION-rhel-server-releases-optional: rhui2-cds02.eu-west-1.aws.ce.redhat.com
 * rhui-REGION-rhel-server-rh-common: rhui2-cds02.eu-west-1.aws.ce.redhat.com
 * rhui-REGION-rhs-console-3.0-rpms: rhui2-cds02.eu-west-1.aws.ce.redhat.com
 * rhui-REGION-rhs-server-3.0-rpms: rhui2-cds02.eu-west-1.aws.ce.redhat.com
 * rhui-REGION-rhs-server-bigdata-3.0-rpms: rhui2-cds02.eu-west-1.aws.ce.redhat.com
https://rhui2-cds02.eu-west-1.aws.ce.redhat.com/pulp/repos//rhui-client-config/rhel/server/6/x86_64/rhs/6/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 401 Authorization Required"
Trying other mirror.
https://rhui2-cds01.eu-west-1.aws.ce.redhat.com/pulp/repos//rhui-client-config/rhel/server/6/x86_64/rhs/6/repodata/repomd.xml: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 401 Authorization Required"
Trying other mirror.
Error: Cannot retrieve repository metadata (repomd.xml) for repository: rhui-REGION-client-config-server-6-rhs. Please verify its path and try again


Expected results:

yum update should succeed

Additional info:

This image consists of RHGS packages for an existing release i.e RHS 3.0
Comment 3 dgao 2015-08-04 07:49:20 EDT
This problem is caused by expired cert and is fixed in version 2.2-122-1.
Comment 5 mkovacik 2015-08-14 08:14:53 EDT
Created attachment 1062999 [details]
Reproducer screen log

Reproduced on the same ami-b560f7c2
Comment 6 mkovacik 2015-08-14 08:21:53 EDT
Created attachment 1063003 [details]
Verifying screen log

Verified in rh-amazon-rhui-client-rhs30-2.2.122-1.el6.noarch

Note You need to log in before you can comment on or make changes to this bug.