Bug 1248049 - Failed to create numa node to pinned vm via REST
Failed to create numa node to pinned vm via REST
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.6.0
All Linux
unspecified Severity high
: ovirt-3.6.1
: ---
Assigned To: Roman Mohr
Artyom
: AutomationBlocker, Triaged
Depends On:
Blocks: 1211176 1265815
  Show dependency treegraph
 
Reported: 2015-07-29 09:58 EDT by Artyom
Modified: 2016-04-19 21:11 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The check for the preferred host list never succeeded when adding virtual numa nodes. Consequence: You could not pin or unpin virtual numa nodes in the UI or through REST. Fix: Fix the check if there are no preferred hosts provided on numa node creation and fetch the preferred hosts from the database in this case. Result: Creating and pinning numa nodes works from UI and REST.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-19 21:11:49 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: SLA
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log which contains the error when creating numa nodes via rest or via the host context menu (53.84 KB, text/plain)
2015-09-23 11:02 EDT, Roman Mohr
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 46535 master MERGED core: Fix detection of preferred hosts for numa nodes Never
oVirt gerrit 47606 ovirt-engine-3.6 MERGED core: Fix detection of preferred hosts for numa nodes Never

  None (edit)
Description Artyom 2015-07-29 09:58:12 EDT
Description of problem:
Failed to create numa node to pinned vm via REST

Version-Release number of selected component (if applicable):
ovirt-engine-3.6.0-0.0.master.20150726172446.git65db93d.el6.noarch

How reproducible:
Always

Steps to Reproduce:
1. Create vm and pin it to host with numa architecture via REST it must looks like:
<placement_policy>
<host href= "/ovirt-engine/api/hosts/3cb9b4ca-ec11-4ebd-bc9f-c632c322865a" id="3cb9b4ca-ec11-4ebd-bc9f-c632c322865a"/>
<affinity>pinned</affinity>
</placement_policy>
2. Try to create numa node to vm via REST:
<vm_numa_node>
    <index>0</index>
    <memory>1024</memory>
    <cpu>
        <cores>
            <core index="0"/>
            <core index="1"/>
        </cores>
    </cpu>
</vm_numa_node>
3.

Actual results:
fault>
<reason>Operation Failed</reason>
<detail>
[Cannot ${action} ${type}. VM must be pinned to a host.]
</detail>
</fault>

Expected results:
Action must succeed

Additional info:
Via UI all works fine
Comment 2 Roman Mohr 2015-09-23 11:02 EDT
Created attachment 1076256 [details]
Log which contains the error when creating numa nodes via rest or via the host context menu

This error does not only happen when you want to add a node through rest. It also happens when you want to pin or unpin a numa node through the host numa pinning dialog:

1) go to hosts tab
2) rightclick on host with numa support
3) select "NUMA Support"
4) Try to pin or unpin a numa node

Logs for rest pinning and host dialog pinning attached.

So currently the only way to do pinning or unpinning is inside the VM configuration form.
Comment 3 Sandro Bonazzola 2015-10-26 08:41:00 EDT
this is an automated message. oVirt 3.6.0 RC3 has been released and GA is targeted to next week, Nov 4th 2015.
Please review this bug and if not a blocker, please postpone to a later release.
All bugs not postponed on GA release will be automatically re-targeted to

- 3.6.1 if severity >= high
- 4.0 if severity < high
Comment 4 Artyom 2015-11-29 05:35:36 EST
Verified on rhevm-restapi-3.6.1-0.2.el6.noarch
Succeed to create numa node to pinned vm via REST

Note You need to log in before you can comment on or make changes to this bug.