Bug 124805 - Kudzu problems with 2 network devices
Kudzu problems with 2 network devices
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-30 10:37 EDT by Avi Alkalay
Modified: 2014-03-16 22:45 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-27 17:43:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Avi Alkalay 2004-05-30 10:37:45 EDT
Description of problem:
The DWL-520 wireless PCI works perfectly with the orinoco_pci kernel 
driver.

But everytime I turn the mahcine on, kudzu allways has 2 questions 
for me.

--------------------------

Version-Release number of selected component (if applicable):
kudzu-1.1.62-1

--------------------------

How reproducible:


Steps to Reproduce:
1. Put a US$30 commodity D-Link DWL-520 wireless PCI card in your FC2.
2. Turn it on and wait for a kudzu message.
3. You'll see both "removed" and "included" message.
  
Actual results:
Kudzu detects everytime 2 inconsistent HW modifications:
1. A Wavelan chipset was removed from your system.
2. A Wavelan chipset was addedd to your system.


Expected results:
Detect it once and never more.



Additional info:
I looked into /etc/hwconf and I found 2 entries for this board !! :

-
class: NETWORK
bus: PCI
detached: 0
device: eth2
driver: orinoco_pci
desc: "Intersil Corporation|Prism 2.5 Wavelan chipset"
vendorId: 1260
deviceId: 3873
subVendorId: 1186
subDeviceId: 3501
pciType: 1
pcidom:    0
pcibus:  0
pcidev:  d
pcifn:  0
-
class: NETWORK
bus: PCI
detached: 1
device: eth1
driver: orinoco_pci
desc: "Intersil Corporation|Prism 2.5 Wavelan chipset"
vendorId: 1260
deviceId: 3873
subVendorId: 1186
subDeviceId: 3501
pciType: 1
pcidom:    0
pcibus:  0
pcidev:  d
pcifn:  0


I obviously have only 1 board. Look at the 'detached' field.


The lspci for this board:
bash# lspci
00:00.0 Host bridge: Advanced Micro Devices [AMD] AMD-751 [Irongate] 
System Controller (rev 23)
00:01.0 PCI bridge: Advanced Micro Devices [AMD] AMD-751 [Irongate] 
AGP Bridge (rev 01)
00:04.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super 
South] (rev 1b)
00:04.1 IDE interface: VIA Technologies, Inc. 
VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:04.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 
Controller (rev 0e)
00:04.3 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 
Controller (rev 0e)
00:04.4 SMBus: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI] 
(rev 20)
00:04.5 Multimedia audio controller: VIA Technologies, Inc. VT82C686 
AC97 Audio Controller (rev 21)
00:0d.0 Network controller: Intersil Corporation Prism 2.5 Wavelan 
chipset (rev 01)
00:0e.0 Multimedia video controller: Brooktree Corporation Bt878 
Video Capture (rev 02)
00:0e.1 Multimedia controller: Brooktree Corporation Bt878 Audio 
Capture (rev 02)
00:10.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-
8139/8139C/8139C+ (rev 10)
01:05.0 VGA compatible controller: Intel Corp. i740 (rev 21)


bash# lspci -v
......
00:0d.0 Network controller: Intersil Corporation Prism 2.5 Wavelan 
chipset (rev 01)
        Subsystem: D-Link System Inc DWL-520 Wireless PCI Adapter
        Flags: medium devsel, IRQ 11
        Memory at efcfe000 (32-bit, prefetchable)
        Capabilities: [dc] Power Management version 2
.....
Comment 1 Dario Prester 2004-07-30 02:01:47 EDT
I have the same problem with wireless card Netgear MA311. Every time 
I boot the box, kudzu detects an hardware change: an old card has 
removed and then a new card has added. When the system is run, I see 
by system-config-network that there are 2 cards detected but just one 
correctly configured and working. Fortunately, the only real card 
works properly
Comment 2 Avi Alkalay 2004-07-30 05:59:59 EDT
I looks like the problem is not specific to the DWL device, but is
happening for me in computers that have 2 network devices: ACM and
ethernet, ou wireless and ethernet. Kudzu all the time detects changes
in them.

For example, my laptop has on board Gig Ethernet and Wireless. It
detects removal and resinretion of both. And it sometimes changes the
order of them: what was eth0 becomes eth1 and vice-versa, making a big
mess with network configutarions of the ifcfg-eth* files. On my system
eth0 should be DHCP and eth1 fixed. And on some boots they are being
switched on /etc/modprobe.conf without swicth in the ifcfg-eth* files.

Big mess.
Comment 3 Alessio Milan 2004-08-18 11:31:28 EDT
The same for me with Netgear MA311. I fixed removing the extra device
using system-config-network and telling kudzu to keep configuration.
Anynow I can bring up the adapter only when I set "Activate on boot",
if I try to activate it later using the "Activate" button on
system-config-network it hangs, so I have to switch on the access
point before booting the system.
Comment 4 Alessio Milan 2004-08-23 06:05:48 EDT
The user activation works well now after installing the update
system-config-network-1.3.17-0.FC2.1
Comment 5 Bill Nottingham 2004-08-27 18:43:22 EDT
Please try the test RPMS at:

http://people.redhat.com/notting/kudzu/
Comment 6 Bill Nottingham 2004-09-27 17:43:54 EDT
Should be fixed in the last kudzu update for FC2.

Note You need to log in before you can comment on or make changes to this bug.