Bug 1248068 - No sound through speakers
No sound through speakers
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
22
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-29 10:18 EDT by Juan Shin
Modified: 2016-01-22 10:05 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-01-22 10:05:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
alsa-info output (18.34 KB, text/plain)
2015-07-29 10:18 EDT, Juan Shin
no flags Details

  None (edit)
Description Juan Shin 2015-07-29 10:18:08 EDT
Created attachment 1057329 [details]
alsa-info output

Description of problem:

No sound through speakers and working with jack (headphone).

Version-Release number of selected component (if applicable):

pulseaudio-6.0-2.fc22.i686

How reproducible:

Steps to Reproduce:
1.Boot and log in
2.Play some music with mplayer/mocp/...
3.Music doesn't come out through speakers
4.Connect a headphone and listen to the music. 

Actual results:

Can't use the builtin speakers for anything. 

Expected results:

Can listen to sound through the speakers

Additional info:

Alsa-info attached
Comment 1 Juan Shin 2015-07-29 10:22:53 EDT
It's been the issue since Fedora 19 at least.

Working or not with each update/upgrade randomly.
Comment 2 lionghostshop 2015-08-01 20:39:18 EDT
My thinkpad t440p does not have sound when using audio jack and has sound using internal speaker. It has the problem since recent update. It worked quite well before. 
My lspci result:
00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor DRAM Controller (rev 06)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor PCI Express x16 Controller (rev 06)
00:01.1 PCI bridge: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor PCI Express x8 Controller (rev 06)
00:02.0 VGA compatible controller: Intel Corporation 4th Gen Core Processor Integrated Graphics Controller (rev 06)
00:03.0 Audio device: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor HD Audio Controller (rev 06)
00:14.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB xHCI (rev 04)
00:16.0 Communication controller: Intel Corporation 8 Series/C220 Series Chipset Family MEI Controller #1 (rev 04)
00:19.0 Ethernet controller: Intel Corporation Ethernet Connection I217-LM (rev 04)
00:1a.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #1 (rev d4)
00:1c.1 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #2 (rev d4)
00:1d.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation QM87 Express LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 8 Series/C220 Series Chipset Family 6-port SATA Controller 1 [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 8 Series/C220 Series Chipset Family SMBus Controller (rev 04)
02:00.0 VGA compatible controller: NVIDIA Corporation GK208M [GeForce GT 730M] (rev a1)
03:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS5227 PCI Express Card Reader (rev 01)
04:00.0 Network controller: Intel Corporation Wireless 7260 (rev 83)
Comment 3 lionghostshop 2015-08-01 20:40:39 EDT
Mine version: pulseaudio-6.0-8.fc22.x86_64 and kernel-4.1.3-201.fc22.x86_64
Comment 4 lionghostshop 2015-08-05 08:54:22 EDT
It seems that the problem is gone now. I don't know why.
Comment 5 Rex Dieter 2015-08-05 09:43:51 EDT
Probably (finally) fixed in recent kernel audio drivers used on your system(s)
Comment 6 lionghostshop 2015-08-06 07:31:03 EDT
It occurs again.
My thinkpad t440p does not have sound when using audio jack and has sound using internal speaker.
Comment 7 lionghostshop 2015-08-06 07:31:29 EDT
I didn't change any software package nor update.
Comment 8 lionghostshop 2015-08-07 22:26:52 EDT
It seems that the problem occurs randomly.
Comment 9 Juan Shin 2015-09-24 09:44:59 EDT
The issue seems to have been fixed for me with recent updates on Fedora 22. 

Sorry for the delay but I haven't got a connection for a while but I have been using the laptop for 2 months without sound though. :S 

Let's see how much time it takes to be broken again. :S


Cheers and thanks!!
Comment 10 Rex Dieter 2015-09-24 09:54:09 EDT
Thanks, closing.
Comment 11 Juan Shin 2015-10-14 05:52:30 EDT
Sadly it's happening again.

Fresh boot (Fedora 22) and nothing sounds through speakers. 

>uname -a
Linux uni 4.1.7-200.fc22.i686 #1 SMP Mon Sep 14 20:52:36 UTC 2015 i686 i686 i386 GNU/Linux

Last month sometimes worked and sometimes didn't.


Something that never worked at all is sound through speakers after a laptop resume.

No issue at all with a pair of headphones though.

So:
*No sound through speakers after a laptop resume ever
*Sometimes no sound through speakers after a fresh boot
*No issue at all with a pair of headphones ever


Cheers
Comment 12 Juan Shin 2015-10-14 06:08:04 EDT
Sorry my bad,
I had the speakers muted so I can confirm that they are working properly. :)

But I can confirm also that after a suspend/resume they stopped working again and no sound through them. 

If I check pavucontrol -t 3 they are not muted and there is audio in the line but you can hear nothing. 


Cheers and sorry.
P.S: should I open a new ticket for this kind of issue?
Comment 13 Rex Dieter 2016-01-22 10:05:43 EST
Yes, one bug per issue please, thanks (ideally against alsa-lib, since it appears to be most likely a driver issue)

Note You need to log in before you can comment on or make changes to this bug.