Bug 124810 - Partition Tables and Intilizations
Partition Tables and Intilizations
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: e2fsprogs (Show other bugs)
2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Thomas Woerner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-30 12:08 EDT by Rich
Modified: 2008-08-02 19:40 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-25 15:38:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rich 2004-05-30 12:08:48 EDT
Description of problem: Could be just my early morning attitude but 
the main problem is that i wasted a day downloding FC2 to have it say 
my partition tables are screwed and to leave me no choice but to 
ignore and not initialize hde and hdg due to fear of loosing my 
windows or raid array data. install took place and on reboot hangs at
hostname...  all defualt boot so its x 


Version-Release number of selected component (if applicable):FEDORA 
CORE2 DVD.iso


How reproducible:HAppens everytime I try to reinstall


Steps to Reproduce:
1.choose remove existing FC1 install
2.ignore partition table error and dont initialize hde & hdg choose 
auto partition
3.full install and reboot
  
Actual results:


Expected results:A nice new shiny FC2 os up and running


Additional info:usb keyboard and mouse.... mouse always detected as 
ps2... and for gods sake make FC nvidia ready!
Comment 1 Rich 2004-05-30 14:41:17 EDT
ok I got runtime 3 working... 
all i can tell you is what i see at the point of hanging. 
mounts root filesystem OK 
loads default keymap US OK 
Initializes usb controllers ehci ohci uhci OK 
mounts usb filesytem OK 


checking root filesytem 

hung right there reset button to reboot. 

so i cant do jack with it right? 
Comment 2 Rich 2004-05-30 20:08:44 EDT
removed linux partitions did a little resize with partition magic for 
a little more room rebooted to dvd again with the "partition tables 
are fooked"... wouldnt see free space on drive for installation auto 
rebooted... im pissed thourghly now... but decide to try linux 
text... it finds empty space and i do autmated partitioning,install 
completes, reboot,
im hung again.......................................................

Say so long to Fedora Core 2.... as practical as peeing against the 
wind.

It would be nice...  well if it worked but even if it did: To list 
hd's and partitions prior to the hde needs to be initalized and ALL 
DATA LOST FOREVER!  so one would know that hey thats my NTFS Raid 
drive... ignore this drive whatever the means.   Good day Rich
Comment 3 Bill Nottingham 2004-06-01 16:31:30 EDT
Assigning to e2fsprogs, as that's the point at which it hung.
Comment 4 Rich 2004-06-02 12:56:29 EDT
Please excuse my disgruntled reply.

Upon further trials and errors I removed my Promise Fastrack 100 PCI 
Raid Controller and rebooted machine successfully. poked around a bit 
and shut machine down, replaced Raid Card and booted back to Fedora 
Core 2 runlevel 5 and she sat there a bit long and booted up.
I still get a hang once in awhile booting but seems to get by the 
problem.

So it seems that the main problem is getting past first boot.
Comment 5 Thomas Woerner 2004-06-03 05:54:39 EDT
Are you using this FastTrack controller for a raid array and is your
root partition on that array?
Comment 6 Rich 2004-06-03 11:16:03 EDT
Yes it is a Raid 0 with my windows NTFS Partition.
No Linux Partitions on it.
Comment 7 Rich 2004-06-05 20:23:57 EDT
Ok I flashed my Plextor DVD writer's firmware from within windows and 
now I'm hanging at setting up local disks again.I am going to remove 
the Raid card again so Fedora Core can set things up again. I imagine 
that will do the trick again as noted above on "first boot".

On A side note I notice that upon rebooting from Fedora Core that the 
Promise Raid Utility has to Spin up my disks in order to 
recognize/initialize whatever. Raid Utility:...................spin 
fast.......... raid detected.
Whereas rebooting from windows they are detected much faster with no 
spin up.
I would assume this is due to no driver for the card under Fedora 
Core 2, so that it sits dormant.

PS If you get any news on A driver for this card I would much 
appreciate an email.

Thanks  Rich 
Comment 8 Rich 2004-06-06 18:41:27 EDT
Affiramtive remove card and Fedora Core Handles Hardware change.
Comment 9 Thomas Woerner 2004-10-04 09:41:21 EDT
Is it hanging at "setting up local disks" in the boot process?
Comment 10 John Thacker 2006-10-25 15:38:52 EDT
Closed per lack of response.  Note that FC2 is not even
supported by Fedora Legacy currently.

Note You need to log in before you can comment on or make changes to this bug.