Bug 1248355 - Fail to S2I build due to cannot find git in $PATH
Fail to S2I build due to cannot find git in $PATH
Status: CLOSED CURRENTRELEASE
Product: OpenShift Container Platform
Classification: Red Hat
Component: Build (Show other bugs)
3.0.0
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Scott Dodson
Gaoyun Pei
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2015-07-30 03:31 EDT by Wenjing Zheng
Modified: 2015-11-23 09:44 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-23 09:44:03 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Wenjing Zheng 2015-07-30 03:31:50 EDT
Description:
Below errors appear when do S2I build:
I0729 23:29:29.698613       1 clone.go:27] Cloning into /tmp/sti962730161/upload/src
I0729 23:29:29.699404       1 clone.go:29] Git clone failed: exec: "git": executable file not found in $PATH
I0729 23:29:29.699428       1 cleanup.go:23] Removing temporary directory /tmp/sti962730161
I0729 23:29:29.699442       1 fs.go:99] Removing directory '/tmp/sti962730161'
F0729 23:29:29.703562       1 builder.go:65] Build error: exec: "git": executable file not found in $PATH

Version-Release number of selected component (if applicable):
openshift v3.0.1.0-503-g7cc6deb
kubernetes v1.0.0
rcm-img-docker01.build.eng.bos.redhat.com:5001/openshift3/ose-sti-builder:v3.0.1.0 (d3594f340b5e)

How reproducible:
always

steps to Reproduce:
1. Create a new project
2. Build with sample S2I json file 
oc new-app https://raw.githubusercontent.com/openshift/origin/master/examples/sample-app/application-template-stibuild.json
3. Watch the build status and build-log

Actual results:
Build will go failed due to cannot find git in $PATH.

Expected results:
It should succeed.

Additional info:
# docker pull registry.access.redhat.com/openshift3/ose-sti-builder
#  docker tag -f registry.access.redhat.com/openshift3/ose-sti-builder  registry.access.redhat.com/openshift3/ose-sti-builder:v3.0.1.0
Then re-build app, everything is working well.
so  the root cause is  rcm-img-docker01.build.eng.bos.redhat.com:5001/openshift3/ose-sti-builder:v3.0.1.0  (d3594f340b5e) has issues.
Comment 2 Cesar Wong 2015-07-30 09:05:24 EDT
Scott, assigning this one to you as it seems a bad image:

Additional info:
# docker pull registry.access.redhat.com/openshift3/ose-sti-builder
#  docker tag -f registry.access.redhat.com/openshift3/ose-sti-builder  registry.access.redhat.com/openshift3/ose-sti-builder:v3.0.1.0
Then re-build app, everything is working well.
so  the root cause is  rcm-img-docker01.build.eng.bos.redhat.com:5001/openshift3/ose-sti-builder:v3.0.1.0  (d3594f340b5e) has issues.
Comment 3 Scott Dodson 2015-07-30 09:32:32 EDT
Our base image failed to install all of its packages. Need to make sure that when things like this fail, they fail hard.
Comment 4 Scott Dodson 2015-07-30 15:48:18 EDT
Fixed in :

rcm-img-docker01.build.eng.bos.redhat.com:5001/openshift3/ose-sti-builder:v3.0.1.0 9a8b15996843
Comment 5 Wenjing Zheng 2015-07-31 01:52:31 EDT
Verified with update image, S2I build works well now:
virt-openshift-08.lab.eng.nay.redhat.com:5000/openshift3/ose-sti-builder          9a8b15996843

openshift v3.0.1.0-525-geddc479
kubernetes v1.0.0

Note You need to log in before you can comment on or make changes to this bug.