Bug 124840 - Installation aborted due to unformatted swap device
Installation aborted due to unformatted swap device
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-05-31 01:13 EDT by Manfred Spraul
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-06-01 16:26:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Manfred Spraul 2004-05-31 01:13:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; fr-FR; rv:1.6) Gecko/20040510

Description of problem:
Fedora Core 1 with one swap partition, listed in /etc/fstab:
/dev/hda5 swap  swap    defaults        0 0

But /dev/hda5 was not formatted as swap device.

During upgrade anaconda tries to enable the swap partition. This fails
and anaconca only offers to reboot.

384 MB system ram.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install FC 1 with a swap partition
2. reuse the swap partition for another purpose (reiserfs tests,
whatever) 
3. Upgrade to FC 2.
    

Actual Results:  Upgrade Aborted due to failed mount of the swap partition

Expected Results:  Screen with question: "Should the swap partition be
formatted" and then retry of the swapon -a. Perhaps even "Continue
without swap" option.

Additional info:
Comment 1 Jeremy Katz 2004-06-01 16:26:17 EDT
Swap is required because upgrades tend to take a lot of memory.  If
your fstab isn't correct, then all bets as far as upgrades have to be
off, there are too many other things that could then be inconsistent
and thus it's better to have the user fix their system instead of
blindly upgrading and breaking things further.

Note You need to log in before you can comment on or make changes to this bug.