Bug 1248472 - [RFE] Content Partition Mounts should be enhanced for kickstart
[RFE] Content Partition Mounts should be enhanced for kickstart
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: preupgrade-assistant-contents (Show other bugs)
6.8
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Petr Hracek
Michal Kovarik
: Extras, FutureFeature, Patch
Depends On:
Blocks: 1252916
  Show dependency treegraph
 
Reported: 2015-07-30 07:30 EDT by Petr Hracek
Modified: 2015-11-19 18:32 EST (History)
8 users (show)

See Also:
Fixed In Version: preupgrade-assistant-contents-0.6.35-1
Doc Type: Enhancement
Doc Text:
To improve Kickstart generation by the Preupgrade assistant on RHEL 7 systems, content partition mounts now contain important information regarding partition, mount, list of block devices. As a result, the Preupgrade assistant is able to generate a Kickstart for RHEL 7 system based on old systems.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-11-19 18:32:39 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
anaconda-ks.cfg (1.48 KB, text/plain)
2015-08-05 05:00 EDT, Michal Kovarik
no flags Details
data.txt (4.15 KB, application/octet-stream)
2015-08-05 05:00 EDT, Michal Kovarik
no flags Details
raid-anaconda-ks.cfg (1.11 KB, text/plain)
2015-08-11 08:16 EDT, Michal Kovarik
no flags Details
raid-data.txt (873 bytes, text/plain)
2015-08-11 08:16 EDT, Michal Kovarik
no flags Details
raid.ks (490 bytes, text/plain)
2015-08-11 08:16 EDT, Michal Kovarik
no flags Details

  None (edit)
Description Petr Hracek 2015-07-30 07:30:46 EDT
Description of problem:
Nowadays 'PartitionMounts' content stores /etc/fstab and /proc/partitions to /root/preupgrade directory.
Content should be enhanced so that it will stores partition layout about devices which are needed by kickstart.

Commands which can be used for it are e.g.: pvs, vgdisplay, lsblk, blkid etc.
Comment 2 Petr Hracek 2015-08-05 03:26:46 EDT
Hi Michal,

would you be able to provide output of commands like:
- lsblk -r
- pvs 
- vgs 
- lvdisplay -C 

All those commands are list/row based outputs.

Could you please also attach anaconda-ks.cfg file?

It would be welcome if machine will be raid, crypted and whatever you want.
Let's say complicated partitioning.
Comment 3 Michal Kovarik 2015-08-05 05:00:01 EDT
Created attachment 1059381 [details]
anaconda-ks.cfg
Comment 4 Michal Kovarik 2015-08-05 05:00:03 EDT
Created attachment 1059382 [details]
data.txt
Comment 5 Michal Kovarik 2015-08-06 09:41:59 EDT
Layout description:

VG created from:
encrypted pv (sda2)
pv(sda3)
encrypted RAID5(md0) created from 3 partitions (sda6,sda7,sd8)

LV:
encrypted lv_data mounted to /data
lv_root mounted to /


swap(sda5)
/boot(sda1)
Comment 6 Petr Hracek 2015-08-07 04:37:11 EDT
Preupgrade-assistant is not able to create a partitioning layout with LVM and disc drive devices.

https://github.com/phracek/preupgrade-assistant/commit/28dc6a6138f800de0119a7b72e00e5ebc6cb6fd0

When the raid devices will be supported then I will switch this bugzilla to POST.
Comment 7 Michal Kovarik 2015-08-11 08:15:59 EDT
adding example of raid device:

'/' on raid1 device from 2 partitions
'/home' on encrypted raid0 device from 2 partitions
Comment 8 Michal Kovarik 2015-08-11 08:16:09 EDT
Created attachment 1061472 [details]
raid-anaconda-ks.cfg
Comment 9 Michal Kovarik 2015-08-11 08:16:10 EDT
Created attachment 1061473 [details]
raid-data.txt
Comment 10 Michal Kovarik 2015-08-11 08:16:12 EDT
Created attachment 1061474 [details]
raid.ks
Comment 13 Alois Mahdal 2015-08-17 18:13:01 EDT
Can you be specific about what this change does?  Description does not do it for me.

(In reply to Petr Hracek from comment #0)
> Description of problem:
> Nowadays 'PartitionMounts' content stores /etc/fstab and /proc/partitions to
> /root/preupgrade directory.

OK.

> Content should be enhanced so that it will stores partition layout about
> devices which are needed by kickstart.

What are "devices which are needed by kickstart?"  Shouldn't it store all layout info?

Also, what is the format of the data, is that simply output from mentioned commands (in separate files)?  Or is that a YAML/JSON/XML/whatever structure?  And scope of the data?  Do I guess right that it's what one could see from the commands mentioned in comment 2?
Comment 14 Petr Hracek 2015-08-31 03:48:54 EDT
(In reply to Alois Mahdal from comment #13)
> Can you be specific about what this change does?  Description does not do it
> for me.
> 
We have to enhanced the content so that we are able to reconstruct partition layout for kickstart usage.

> (In reply to Petr Hracek from comment #0)
> > Description of problem:
> > Nowadays 'PartitionMounts' content stores /etc/fstab and /proc/partitions to
> > /root/preupgrade directory.
> 
> OK.
> 
> > Content should be enhanced so that it will stores partition layout about
> > devices which are needed by kickstart.
> 
> What are "devices which are needed by kickstart?"  Shouldn't it store all
> layout info?
> 
Yes, it stores all layout info definitely.

> Also, what is the format of the data, is that simply output from mentioned
> commands (in separate files)?  Or is that a YAML/JSON/XML/whatever
> structure?  And scope of the data?  Do I guess right that it's what one
> could see from the commands mentioned in comment 2?

Format data is row-based and separated by ';' for better parsing.
Data are taken by commands lsblk, vgs etc.

I did not update Doc Text yet. I will do it ASAP.
Comment 18 Michal Kovarik 2015-09-09 06:42:45 EDT
Verified with preupgrade-assistant-contents-0.6.36-1.el6.noarch and preupgrade-assistant-2.1.0-6.el6.x86_64. Required files are created and used by preupgrade-assistant for kickstart creation.
Comment 20 errata-xmlrpc 2015-11-19 18:32:39 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-2498.html

Note You need to log in before you can comment on or make changes to this bug.